Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Unable to display Dina bitmap font #44

Open
seschwar opened this Issue Apr 15, 2012 · 2 comments

Comments

Projects
None yet
2 participants

I use the Dina font -- obtainable in PCF format for example from kernel.org -- with urxvt and dmenu. xmobar 0.14 however is unable to display it and just falls back to the default X11 font fixed.

Until recently I was just using the specification xft:Dina:pixelsize=16 as a workaround. But then I disabled bitmap fonts in fontconfig to prevent Firefox from using them in certain rare cases. Obviously using bitmap fonts via xft: no longer works. But why doesn't -*-dina-medium-r-*-*-16-*-*-*-*-*-*-* work in the first place? Dmenu, dzen and urxvt have no problem with the font.

Owner

jaor commented Apr 15, 2012

I'll have to investigate, but i have a similar issue with terminus. To
make xmobar find it i need the specification as

    -xos4-terminus-medium-r-normal-*-12-120-*-*-*-*-*-*"

Can you try to fill in some the '*' in your dina spec (needless to say,
with their real values, not mine) to see if that works?

Even fully specified like the following dina does not work:

-windows-dina-medium-r-normal--16-100-96-96-c-80-microsoft-cp1252

However a minimally specified terminus does work here:

-*-terminus-*-*-*-*-*-*-*-*-*-*-*-*
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment