Skip to content
This repository

OAuth 1.0 and 2.0 authentication strategies for Passport and Node.js.

README.md

passport-oauth

Build Coverage Dependencies

General-purpose OAuth 1.0 and OAuth 2.0 authentication strategies for Passport.

This is a meta-module that combines passport-oauth1 and passport-oauth2. It exists for backwards-compatibility with the 0.1.x line of OAuth-based strategies. As of version 1.x.x, it is encouraged to declare dependencies on the module that implements specific version of OAuth in use.

Install

$ npm install passport-oauth

Tests

$ npm install
$ npm test

Credits

License

The MIT License

Copyright (c) 2011-2013 Jared Hanson <http://jaredhanson.net/>

Something went wrong with that request. Please try again.