New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Google+ Sign-In Deprecation #713

Open
ginovski opened this Issue Jan 30, 2019 · 4 comments

Comments

Projects
None yet
4 participants
@ginovski
Copy link

ginovski commented Jan 30, 2019

Hi there,

We are using passport.js to authenticate people with their Google account. And I'm receiving emails from Google last days that we are using something that's going to be fully deprecated. Screenshot of the email below:

screenshot 2019-01-30 at 10 40 44

Here is the code we have for authentication:

const options = {
authType: "rerequest",
state: JSON.stringify(data),
session: false,
failureRedirect: "/login",
scope: ["profile", "email"],
};
passport.authenticate("google", options)(req, res, next);

Are you going to update the api you are making requests to? Or should I update something in my code?

Environment

  • passport@0.3.2
  • passport-google-oauth20@1.0.0
@devalexqt

This comment has been minimized.

Copy link

devalexqt commented Jan 31, 2019

Same problem.

@tima101

This comment has been minimized.

Copy link

tima101 commented Jan 31, 2019

@ginovski You can use forked package for now: builderbook/builderbook#195


EDIT: solution suggested by @archiebaer does look simpler : https://stackoverflow.com/a/54112673/10124491

@ginovski

This comment has been minimized.

Copy link
Author

ginovski commented Feb 1, 2019

@jaredhanson Are you going to review this PR?
jaredhanson/passport-google-oauth2#51

@archiebaer

This comment has been minimized.

Copy link

archiebaer commented Feb 3, 2019

You may find this useful: https://stackoverflow.com/a/54112673/10124491

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment