Adding default to AutoEntry breaks it #143

Closed
jarvisteach opened this Issue Apr 11, 2017 · 1 comment

Comments

Projects
None yet
1 participant
@jarvisteach
Owner

jarvisteach commented Apr 11, 2017

As highlighted in #110 adding defaults to AutoEntries causes an empty drop-down to show.

When appJar launches, the drop-down will be in the top-left of the UI - not sure why yet.

After you manage to get rid of it, it'll show in the right place the next time, but still shouldn't be showing.

If it happens that the default text is in the drop-down, that will be shown. But clicking it doesn;t select it... Otherwise nothing is shown.

@jarvisteach jarvisteach added the bug label Apr 11, 2017

@jarvisteach jarvisteach added this to the 0.06 milestone Apr 11, 2017

@jarvisteach jarvisteach self-assigned this Apr 11, 2017

jarvisteach added a commit that referenced this issue Apr 11, 2017

Fixed defaults for AutoEntries (#143)
Disable auto completion trace when setting default text. This required
storing the trace as a variable, and setting an empty variable for
normal entries.

Also changed setDefaultEntry, to only populate if no text is already
being shown.

Also changed updateDefaultText() to updateEntryDefault() - included
deprecated message. Added an “update” option to the main function.

Updated documentation to mention updateEntryDefault()
@jarvisteach

This comment has been minimized.

Show comment
Hide comment
@jarvisteach

jarvisteach Apr 11, 2017

Owner

Should be resolved.

Owner

jarvisteach commented Apr 11, 2017

Should be resolved.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment