Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Cluster test fails on Windows #2891

Closed
vendethiel opened this Issue Mar 25, 2013 · 4 comments

Comments

Projects
None yet
3 participants
Collaborator

vendethiel commented Mar 25, 2013

From #2846. I'm running Windows8 64bits & Node .8.2

> cake test

coffee-script-master\test\cluster.coffee:1
# Cluster Module
^

module.js:437
  var compiledWrapper = runInThisContext(wrapper, filename, true);
                        ^
SyntaxError: Unexpected token ILLEGAL
    at Module._compile (module.js:437:25)
    at Object.Module._extensions..js (module.js:467:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.runMain (module.js:492:10)
    at process.startup.processNextTick.process._tickCallback (node.js:244:9)

coffee-script-master\Cakefile:116
  task('build:ultraviolet', 'build and install the Ultraviolet syntax highligh
                                             ^
AssertionError: Expected 1 to equal 0
Collaborator

vendethiel commented Mar 25, 2013

The failing line seems to be cluster = require 'cluster'. Probably an extension issue. Need to investigate further

Contributor

hden commented Mar 26, 2013

I can reproduce the error using node v0.8.17 on a mac.

Contributor

epidemian commented Mar 26, 2013

Was happening to me too on Node 0.8.something. Updated to 0.10.0 and it no longer fails.

Contributor

hden commented Mar 26, 2013

It seems that we all missed the docs

The coffee command can now correctly fork() both .coffee and .js files. (Requires Node.js 0.9+)

Perhaps we should ignore the cluster test when process.version turns out to be v0.8 or below?

@vendethiel vendethiel closed this Apr 3, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment