Home

Martin Prout edited this page Dec 1, 2016 · 79 revisions

ruby

The current version of ruby-processing is available from rubygems

gem install ruby-processing

However this version of ruby-processing depends on you having java runtime (jre7+/jdk7+), and a locally installed version of vanilla processing and you should install that first. Required version processing-2.2.1 You must also set the PROCESSING_ROOT in .rp5rc getting started for detailed instructions.

But since 2016 you should install JRubyArt or propane instead

gem install jruby_art # to use the current version of processing
jgem install propane # to use the current version of processing, batteries included

A brief history

Getting Started

From java processing to ruby-processing

FAQs

Render Modes

Built-in Ruby Processing Libraries

Advanced Topics

Gallery

Other Resources

Changelog