Permalink
Browse files

Explicitly enumerate required files in lib.

  • Loading branch information...
1 parent b4116ba commit 6a759841de6f57a08fa8f25fbe6eb2a2e70bcf5b Lee Byrd & Christian Williams committed Jun 23, 2010
Showing with 14 additions and 4 deletions.
  1. +11 −1 Rakefile
  2. +3 −3 jasmine.gemspec
View
@@ -40,7 +40,17 @@ namespace :jeweler do
gemspec.homepage = "http://github.com/pivotal/jasmine-ruby"
gemspec.authors = ["Rajan Agaskar", "Christian Williams"]
gemspec.executables = ["jasmine"]
- gemspec.files = FileList.new('generators/**/**', 'lib/**/**', 'jasmine/lib/**', 'jasmine/contrib/ruby/**', 'tasks/**', 'templates/**')
+ gemspec.files = FileList.new(
+ 'generators/**/**',
+ 'lib/**/**',
+ 'jasmine/lib/consolex.js',
+ 'jasmine/lib/jasmine.css',
+ 'jasmine/lib/jasmine.js',
+ 'jasmine/lib/json2.js',
+ 'jasmine/lib/TrivialReporter.js',
+ 'tasks/**',
+ 'templates/**'
+ )
gemspec.add_dependency('rspec', '>= 1.1.5')
gemspec.add_dependency('rack', '>= 1.0.0')
gemspec.add_dependency('selenium-rc', '>=2.1.0')
View
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{jasmine}
- s.version = "0.10.4.0"
+ s.version = "0.11.0.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Rajan Agaskar", "Christian Williams"]
- s.date = %q{2010-06-22}
+ s.date = %q{2010-06-23}
s.default_executable = %q{jasmine}
s.description = %q{Javascript BDD test framework}
s.email = %q{ragaskar@gmail.com}
@@ -28,8 +28,8 @@ Gem::Specification.new do |s|
"generators/jasmine/templates/spec/javascripts/support/jasmine_runner.rb",
"jasmine/lib/TrivialReporter.js",
"jasmine/lib/consolex.js",
- "jasmine/lib/jasmine.js",
"jasmine/lib/jasmine.css",
+ "jasmine/lib/jasmine.js",
"jasmine/lib/json2.js",
"lib/jasmine.rb",
"lib/jasmine/base.rb",

0 comments on commit 6a75984

Please sign in to comment.