Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

fix reference error of YAML and JSON #119

Merged
merged 1 commit into from Dec 7, 2012

Conversation

Projects
None yet
2 participants
Contributor

kozy4324 commented Dec 4, 2012

v1.3.1 is broken? rake jasmine:ci fail with reference error.

$ gem uninstall jasmine -a
$ gem install jasmine -v 1.3.1
$ mkdir temp && cd $_
$ jasmine init
$ rake jasmine:ci
/Users/k-nakamura/.rvm/rubies/ruby-1.9.3-p194/bin/ruby -S rspec /Users/k-nakamura/.rvm/gems/ruby-1.9.3-p194/gems/jasmine-1.3.1/lib/jasmine/run_specs.rb --colour --format progress
/Users/k-nakamura/.rvm/gems/ruby-1.9.3-p194/gems/jasmine-1.3.1/lib/jasmine/config.rb:69:in `block in load_configuration_from_yaml': uninitialized constant Jasmine::YAML (NameError)
...

adding require 'yaml' to config.rb, another error occurs.

$ rake jasmine:ci
/Users/k-nakamura/.rvm/rubies/ruby-1.9.3-p194/bin/ruby -S rspec /Users/k-nakamura/.rvm/gems/ruby-1.9.3-p194/gems/jasmine-1.3.1/lib/jasmine/run_specs.rb --colour --format progress
Waiting for jasmine server on 59432...
[2012-12-04 18:44:13] INFO  WEBrick 1.3.1
[2012-12-04 18:44:13] INFO  ruby 1.9.3 (2012-04-20) [x86_64-darwin12.2.0]
[2012-12-04 18:44:13] INFO  WEBrick::HTTPServer#start: pid=33916 port=59432
Waiting for jasmine server on 59432...
jasmine server started.
/Users/k-nakamura/.rvm/gems/ruby-1.9.3-p194/gems/jasmine-1.3.1/lib/jasmine/selenium_driver.rb:34:in `eval_js': uninitialized constant Jasmine::SeleniumDriver::JSON (NameError)
...

environment

$ sw_vers
ProductName:    Mac OS X
ProductVersion: 10.8.2
BuildVersion:   12C60
$ rvm --version && ruby --version && rake --version

rvm 1.16.8 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin12.2.0]
rake, version 10.0.2
@kozy4324 kozy4324 fix reference error of YAML and JSON
config.rb needs `require 'yaml'` and selenium_driver.rb needs `require 'json'`
in case of `rake jasmine:ci`
c5b2c9d

@ragaskar ragaskar added a commit that referenced this pull request Dec 7, 2012

@ragaskar ragaskar Merge pull request #119 from kozy4324/fix-yaml-reference-error
fix reference error of YAML and JSON
442135f

@ragaskar ragaskar merged commit 442135f into jasmine:master Dec 7, 2012

1 check passed

default The Travis build passed
Details
Contributor

ragaskar commented Dec 7, 2012

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment