No description or website provided.
Shell
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
apiextractor @ 0208aae
generatorrunner @ 96259b8
pyside @ 69e2171
pyside-tools @ 23e0712
shiboken @ 980b4a9
.gitmodules
README
build_and_install
dependencies.arch.sh
dependencies.fedora.sh
dependencies.meego.sh
dependencies.osx.sh
dependencies.ubuntu.sh
environment.sh

README

Initial setup
=============

    git submodule init
    git submodule update

Install build dependencies
==========================

    On MeeGo:

        sudo ./dependencies.meego.sh

    On Ubuntu:

        sudo ./dependencies.ubuntu.sh

    On Arch Linux:

        sudo ./dependencies.arch.sh

    On Mac OS X (using Homebrew):

        sudo ./dependencies.osx.sh

    On Red Hat Linux, CentOS 6 and Fedora:

        sudo ./dependencies.fedora.sh

Additional dependencies for Mac OS X
====================================

    The dependencies script on Mac OS X does not install a C++ toolchain or
    the Qt libraries. Instead, you should install Xcode and the Qt SDK
    manually:

        http://developer.apple.com/tools/xcode/
        http://qt.nokia.com/downloads/sdk-mac-os-cpp

Build and install
=================

    ./build_and_install

    By default, this will do a Release build. If you want to do a Debug
    build, you have to uncomment the correct line in environment.sh

    If you want to build PySide against the Qt SDK, you have to set the
    environment variable QT_SDK_HOME - this variable needs to be set before
    "environment.sh" is sourced, and before "build_and_install" is run.

Updating to the latest version
==============================

    git submodule foreach git checkout master
    git submodule foreach git pull

Working with the build
======================

    source /path/to/environment.sh
    python /path/to/app.py