Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

missing GLIBCXX_3.4.18 on Ubuntu 12.04 #53

Open
RafaelCz opened this issue Nov 7, 2014 · 14 comments

Comments

@RafaelCz
Copy link

commented Nov 7, 2014

Hi,
after updating to Brackets 1.0 and Backets SASS 1.0.0-68, I get this Error:

Runtime error: Unable to load one of the modules: /home/rafael/.config/Brackets/extensions/user/jasonsanjose.brackets-sass/node/1.1.4/SASSDomain, reason: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /home/rafael/.config/Brackets/extensions/user/jasonsanjose.brackets-sass/node/1.1.4/node_modules/node-sass/bin/linux-x64-v8-3.14/binding.node)

I'm using elementary OS 0.2 Luna (it's based on Ubuntu 12.04.1) with a backported Kernel from Ubuntu 14.04 (linux-generic-lts-trusty). My system is up-to-date, no pending updates.

uname -a

3.13.0-39-generic #66~precise1-Ubuntu SMP Wed Oct 29 09:56:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

The result of strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX is:

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_DEBUG_MESSAGE_LENGTH

It seems like you are linking against a library-version, which is not provided by the Ubuntu 12.04 repository...

@olivierrr

This comment has been minimized.

Copy link

commented Nov 7, 2014

+1

@jasonsanjose

This comment has been minimized.

Copy link
Owner

commented Nov 13, 2014

Looks related to sass/node-sass#517.

@jasonsanjose

This comment has been minimized.

Copy link
Owner

commented Nov 17, 2014

@RafaelCz @olivierrr Can you try the update version 1.0.1-73. I just uploaded it to the extension registry today. I tested the new build on Ubuntu 64-bit 14.04.

I have some new example projects posted with instructions, details here https://github.com/jasonsanjose/brackets-sass/wiki.

@RafaelCz

This comment has been minimized.

Copy link
Author

commented Nov 17, 2014

@jasonsanjose I'm sorry to disappoint you, but I still get the same error:

Runtime error: Unable to load one of the modules: /home/rafael/.config/Brackets/extensions/user/jasonsanjose.brackets-sass/node/1.1.4-1/SASSDomain, reason: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /home/rafael/.config/Brackets/extensions/user/jasonsanjose.brackets-sass/node/1.1.4-1/node_modules/node-sass/bin/linux-x64-v8-3.14/binding.node)

@jasonsanjose jasonsanjose reopened this Nov 17, 2014

@jasonsanjose

This comment has been minimized.

Copy link
Owner

commented Nov 17, 2014

@RafaelCz have you used node-sass on that same machine?

I'm using elementary OS 0.2 Luna (it's based on Ubuntu 12.04.1) with a backported Kernel from Ubuntu 14.04 (linux-generic-lts-trusty). My system is up-to-date, no pending updates.

Install: https://github.com/sass/node-sass#install
Usage: https://github.com/sass/node-sass#command-line-interface

Since node-sass is a dependency for the extension, it would be easier to diagnose the bug if you could try running it independently if you have some spare time. The current version 1.1.4 is the same version used here. Let me know how it goes. Thanks!

@RafaelCz

This comment has been minimized.

Copy link
Author

commented Nov 17, 2014

@jasonsanjose no, till now I did only use brackets with brackets-sass.

Install: https://github.com/sass/node-sass#install
Usage: https://github.com/sass/node-sass#command-line-interface

I installed node.js and tried to install node-sass, but I ran into an error.

info it worked if it ends with ok
verbose cli [ 'node', '/usr/bin/npm', 'install', 'node-sass' ]
info using npm@1.1.4
info using node@v0.6.12
verbose config file /home/rafael/.npmrc
verbose config file /usr/etc/npmrc
verbose config file /usr/share/npm/npmrc
verbose cache add [ 'node-sass', null ]
silly cache add: name, spec, args [ undefined, 'node-sass', [ 'node-sass', null ] ]
verbose parsed url { pathname: 'node-sass', path: 'node-sass', href: 'node-sass' }
verbose addNamed [ 'node-sass', '' ]
verbose addNamed [ null, '' ]
silly name, range, hasData [ 'node-sass', '', false ]
verbose raw, before any munging node-sass
verbose url resolving [ 'https://registry.npmjs.org/', './node-sass' ]
verbose url resolved https://registry.npmjs.org/node-sass
http GET https://registry.npmjs.org/node-sass
ERR! Error: failed to fetch from registry: node-sass
ERR!     at /usr/share/npm/lib/utils/npm-registry-client/get.js:139:12
ERR!     at cb (/usr/share/npm/lib/utils/npm-registry-client/request.js:31:9)
ERR!     at Request._callback (/usr/share/npm/lib/utils/npm-registry-client/request.js:136:18)
ERR!     at Request.callback (/usr/lib/nodejs/request/main.js:119:22)
ERR!     at Request.<anonymous> (/usr/lib/nodejs/request/main.js:212:58)
ERR!     at Request.emit (events.js:88:20)
ERR!     at ClientRequest.<anonymous> (/usr/lib/nodejs/request/main.js:412:12)
ERR!     at ClientRequest.emit (events.js:67:17)
ERR!     at HTTPParser.onIncoming (http.js:1261:11)
ERR!     at HTTPParser.onHeadersComplete (http.js:102:31)
ERR! You may report this log at:
ERR!     <http://bugs.debian.org/npm>
ERR! or use
ERR!     reportbug --attach /home/rafael/npm-debug.log npm
ERR! 
ERR! System Linux 3.13.0-39-generic
ERR! command "node" "/usr/bin/npm" "install" "node-sass"
ERR! cwd /home/rafael
ERR! node -v v0.6.12
ERR! npm -v 1.1.4
ERR! message failed to fetch from registry: node-sass
verbose exit [ 1, true ]

EDIT:
OK, it seems like the node.js version is a little bit outdated :)

@RafaelCz

This comment has been minimized.

Copy link
Author

commented Nov 18, 2014

@jasonsanjose I managed to add the NodeSource-repository and install the current version of node.js
https://github.com/nodesource/distributions

Installing node-sass via npm is still failing, but this time with a familiar error:

> node-sass@1.2.2 install /home/rafael/Downloads/node_modules/node-sass
> node scripts/install.js

     fetch : https://raw.githubusercontent.com/sass/node-sass-binaries/v1.2.2/linux-x64-v8-3.14/binding.node
  progress : [====================] 100% 0.0s

Binary installed in /home/rafael/Downloads/node_modules/node-sass/vendor/linux-x64-v8-3.14

> node-sass@1.2.2 postinstall /home/rafael/Downloads/node_modules/node-sass
> node scripts/build.js

`linux-x64-v8-3.14` exists; testing

module.js:356
  Module._extensions[extension](this, filename);

Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /home/rafael/Downloads/node_modules/node-sass/vendor/linux-x64-v8-3.14/binding.node)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/rafael/Downloads/node_modules/node-sass/lib/index.js:182:15)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

npm ERR! node-sass@1.2.2 postinstall: `node scripts/build.js`
npm ERR! Exit status 8
npm ERR! 
npm ERR! Failed at the node-sass@1.2.2 postinstall script.
npm ERR! This is most likely a problem with the node-sass package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node scripts/build.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls node-sass
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 3.13.0-39-generic
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "node-sass"
npm ERR! cwd /home/rafael/Downloads
npm ERR! node -v v0.10.33
npm ERR! npm -v 1.4.28
npm ERR! code ELIFECYCLE
npm ERR! not ok code 0

@jasonsanjose

This comment has been minimized.

Copy link
Owner

commented Nov 18, 2014

@RafaelCz there's a recommendation in the node-sass issue sass/node-sass#517 (comment) to

Installing libstdc++6-4.7-dev did it for me. On node version 0.10.33 and npm version 2.1.7.

Maybe that will help?

@RafaelCz

This comment has been minimized.

Copy link
Author

commented Nov 19, 2014

@jasonsanjose the latest libstdc++-version povided by the official ubuntu-repository is 6-4.6 😞

@drewnoakes

This comment has been minimized.

Copy link

commented Dec 11, 2014

See the discussion here for more info and a few possible options. You may have to add a PPA to get backports.

@ghost

This comment has been minimized.

Copy link

commented Mar 5, 2015

@RafaelCz I had same problem on Elemantry OS(which based on ubuntu). I solved it by upgrading gcc-4.9 and g++-4.9

@shubhamoy

This comment has been minimized.

Copy link

commented Mar 25, 2015

In my case, I installed: sudo apt-get install libstdc++6

@richelbilderbeek

This comment has been minimized.

Copy link

commented Jul 30, 2016

In my case, I did the following to solve the problem:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install libstdc++6-4.7-dev
@EstevanM

This comment has been minimized.

Copy link

commented Feb 13, 2018

@richelbilderbeek it worked for me, thanks. My problem was running Matlab R2015a on Ubuntu 12.04. It was missing GLIBCXX_3.4.17

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
7 participants
You can’t perform that action at this time.