Permalink
Browse files

remove i18n dev dependency and hope for the best

  • Loading branch information...
1 parent 332bff2 commit 29f7df2524adf4baacc1687c9eca2ab46843a649 @javan committed Dec 15, 2012
Showing with 2 additions and 8 deletions.
  1. +2 −8 whenever.gemspec
View
@@ -15,17 +15,11 @@ Gem::Specification.new do |s|
s.test_files = `git ls-files -- test/{functional,unit}/*`.split("\n")
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
-
+
s.add_dependency "chronic", ">= 0.6.3"
s.add_dependency "activesupport", ">= 2.3.4"
-
+
s.add_development_dependency "shoulda", ">= 2.1.1"
s.add_development_dependency "mocha", ">= 0.9.5"
s.add_development_dependency "rake"
-
- # I'm not sure why this isn't installed along with activesupport,
- # but for whatever reason running `bundle install` doesn't install
- # i18n so I'm adding it here for now.
- # https://github.com/rails/rails/blob/master/activesupport/activesupport.gemspec#L19 ?
- s.add_development_dependency "i18n"
end

1 comment on commit 29f7df2

@kronn
kronn commented on 29f7df2 Dec 18, 2012

Earlier versions of activesupport, namely 2.3.4 came with a bundled version of I18n which was used when no newer version was found on the system. Newer versions (3.0+) have this in their gemspec.

Please sign in to comment.