Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

updated to tika 0.9

  • Loading branch information...
commit 6a027917d0ea68606d3915374ff92249f4dfb928 1 parent 829a7c5
@javasoze authored
View
4 bin/mvn-install.sh
@@ -1,8 +1,4 @@
#!/bin/bash
-echo "installing tika core snapshot..."
-mvn install:install-file -Dfile=lib/tika-core-0.9-SNAPSHOT.jar -DgroupId=org.apache.tika -DartifactId=tika-core -Dversion=0.9-SNAPSHOT -Dpackaging=jar
-echo "installing tika parser snapshot..."
-mvn install:install-file -Dfile=lib/tika-parsers-0.9-SNAPSHOT.jar -DgroupId=org.apache.tika -DartifactId=tika-parsers -Dversion=0.9-SNAPSHOT -Dpackaging=jar
echo "installing htmlcleaner 2.2"
mvn install:install-file -Dfile=lib/htmlcleaner-2.2.jar -DgroupId=org.htmlcleaner -DartifactId=htmlcleaner -Dversion=2.2 -Dpackaging=jar
echo "installing nekohtml 1.9.13"
View
BIN  lib/tika-core-0.9-SNAPSHOT.jar
Binary file not shown
View
BIN  lib/tika-parsers-0.9-SNAPSHOT.jar
Binary file not shown
View
49 meaningfulweb-core/pom.xml
@@ -81,51 +81,6 @@
</dependency>
<dependency>
- <groupId>org.apache.pdfbox</groupId>
- <artifactId>pdfbox</artifactId>
- <version>1.3.1</version>
- </dependency>
- <!-- TIKA-370: PDFBox declares the Bouncy Castle dependencies
- as optional, but we prefer to have them always to avoid
- problems with encrypted PDFs. -->
- <dependency>
- <groupId>org.bouncycastle</groupId>
- <artifactId>bcmail-jdk15</artifactId>
- <version>1.45</version>
- </dependency>
-
- <dependency>
- <groupId>org.bouncycastle</groupId>
- <artifactId>bcprov-jdk15</artifactId>
- <version>1.45</version>
- </dependency>
- <dependency>
- <groupId>org.apache.poi</groupId>
- <artifactId>poi</artifactId>
- <version>${poi.version}</version>
- </dependency>
- <dependency>
- <groupId>org.apache.poi</groupId>
- <artifactId>poi-scratchpad</artifactId>
- <version>${poi.version}</version>
- </dependency>
- <dependency>
- <groupId>org.apache.poi</groupId>
- <artifactId>poi-ooxml</artifactId>
- <version>${poi.version}</version>
- <exclusions>
- <exclusion>
- <groupId>stax</groupId>
- <artifactId>stax-api</artifactId>
- </exclusion>
- <exclusion>
- <groupId>xml-apis</groupId>
- <artifactId>xml-apis</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
-
- <dependency>
<groupId>${project.groupId}</groupId>
<artifactId>meaningfulweb-opengraph</artifactId>
<version>${project.version}</version>
@@ -134,12 +89,12 @@
<dependency>
<groupId>org.apache.tika</groupId>
<artifactId>tika-core</artifactId>
- <version>0.9-SNAPSHOT</version>
+ <version>0.9</version>
</dependency>
<dependency>
<groupId>org.apache.tika</groupId>
<artifactId>tika-parsers</artifactId>
- <version>0.9-SNAPSHOT</version>
+ <version>0.9</version>
</dependency>
<dependency>
<groupId>net.htmlparser.jericho</groupId>
Please sign in to comment.
Something went wrong with that request. Please try again.