Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Class not found org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer with hibernate 5.6.0.X #1134

Closed
pethers opened this issue Aug 29, 2021 · 7 comments

Comments

@pethers
Copy link
Contributor

pethers commented Aug 29, 2021

Clear description of my expectations versus reality
Latest release https://in.relation.to/2021/08/27/hibernate-orm-560-beta1-release/ have dropped class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer used in https://github.com/javers/javers/blob/master/javers-spring-jpa/src/main/java/org/javers/hibernate/integration/HibernateUnproxyObjectAccessHook.java

Steps To Reproduce
Update hibernate to 5.6.0.beta1 using spring jpa with hibernate.

Javers' Version
6.2.4

Additional context
Hibernate from 5.6.0+ only supports bytebuddy for class enhancements.

@pethers
Copy link
Contributor Author

pethers commented Aug 30, 2021

@pethers
Copy link
Contributor Author

pethers commented Sep 3, 2021

@bartoszwalacik
Copy link
Member

thanks for the report, I will check it

@bartoszwalacik
Copy link
Member

Hibernate 5.3 was released in 2018 so dropping support for it seems fine

@bartoszwalacik
Copy link
Member

luckily, dependency to org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer can be simply removed, see https://github.com/javers/javers/pull/1140/files

@pethers
Copy link
Contributor Author

pethers commented Sep 5, 2021

Thanks for fixing this, works with 6.2.5 now.

@bartoszwalacik
Copy link
Member

fixed in 6.2.5

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants