Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Auto project creation #56

Closed
fkrauthan opened this Issue Feb 15, 2015 · 6 comments

Comments

Projects
None yet
2 participants
@fkrauthan
Copy link

fkrauthan commented Feb 15, 2015

I recently tried to turn on the automatic project copy mode. But I always get the error message that it can't find the master project. But if I push to master it finds the project for the master branch and starts building it. Is there more documentation how I have to setup the git repository in my master jenkins job so the plugin can find it?

@javiplx

This comment has been minimized.

Copy link
Owner

javiplx commented Feb 16, 2015

It is very likely that the reason is that your master project has a wildcard on branch specification. If that is the reason, it will get solved on v1.3.0, that will probably be released this week as I'm doing the final documentation review. In the meantime, if you change it to 'origin/master', it should find the master branch, although you will likely hit some other bug already solved on 1.3

@fkrauthan

This comment has been minimized.

Copy link
Author

fkrauthan commented Feb 16, 2015

I tried a lot configurations. It was always able to find the master branch if it had to build the master project. But all pushes to a different branch ended up with the error can't find master branch. Gonna try it when the update to 1.3 is out.

@fkrauthan

This comment has been minimized.

Copy link
Author

fkrauthan commented Feb 20, 2015

Ok it finds now the correct master project with release 1.3 but I have another issue. If it tries to create the project I get the following error:

NameError - no constructorfor arguments (hudson.security.AccessDeniedException2) on Java::OrgJrubyExceptions::RaiseException:
/var/lib/jenkins/plugins/gitlab-hook/WEB-INF/classes/models/api.rb:59:in process_projects' /var/lib/jenkins/plugins/gitlab-hook/WEB-INF/classes/models/api.rb:30:inPOST /build_now'

I think it is related to the fact that I require authentication for my jenkins server.

@javiplx

This comment has been minimized.

Copy link
Owner

javiplx commented Feb 21, 2015

You are right. I though I have added the ACL.impersonate function, but I didn't. I've fixed, and tried to upload a new version for test it, but maven.jenkins-ci.org seems down. In the meantime, you can build your own hpi from branch upstream_1.2.1.

@javiplx

This comment has been minimized.

Copy link
Owner

javiplx commented Feb 23, 2015

The hpi with the fix is available as 1.3.1-SNAPSHOT

@fkrauthan

This comment has been minimized.

Copy link
Author

fkrauthan commented Feb 24, 2015

1.3.1-SNAPSHOT version is working fine for me thanks.

@fkrauthan fkrauthan closed this Feb 24, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.