Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

goto cursor doesn't work on mac os x lion #111

Open
cire831 opened this Issue Aug 12, 2012 · 4 comments

Comments

Projects
None yet
2 participants

cire831 commented Aug 12, 2012

running OLS 0.9.5 on mac os x lion 10.7.4

I set two cursors and if the cursors are off screen, using goto cursor 1 or 2 doesn't work.

Note: The failure occurs when no trigger is active. I just found out that if I have an active trigger then it works fine. Goto home goes to the trigger, and goto cursor takes me to the appropriate cursor. But if no trigger is active, the goto cursor function doesn't work

rubr (9): sw_vers
ProductName: Mac OS X
ProductVersion: 10.7.4
BuildVersion: 11E53
rubr (10): java -version
java version "1.7.0_04"
Java(TM) SE Runtime Environment (build 1.7.0_04-b21)
Java HotSpot(TM) 64-Bit Server VM (build 23.0-b21, mixed mode)
rubr (11):

Owner

jawi commented Aug 13, 2012

Does this problem also occur with the latest beta of 0.9.6 (beta-3)?

cire831 commented Aug 14, 2012

On Mon, Aug 13, 2012 at 2:46 AM, Jan Willem Janssen <
notifications@github.com> wrote:

Does this problem also occur with the latest beta of 0.9.6 (beta-3)?

Don't know.

I tried building from the git sources and it failed to build properly. If
you send me a pointer to a DMG I'll try it.

I just updated to the tip of the git tree (442a7b8). Then followed the
instructions in README.

rubr (21): mvn --version
Apache Maven 3.0.3 (r1075438; 2011-02-28 09:31:09-0800)
Maven home: /usr/share/maven
Java version: 1.7.0_04, vendor: Oracle Corporation
Java home: /Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home/jre
Default locale: en_US, platform encoding: US-ASCII
OS name: "mac os x", version: "10.7.4", arch: "x86_64", family: "mac"
rubr (22): sw_vers
ProductName: Mac OS X
ProductVersion: 10.7.4
BuildVersion: 11E53
rubr (23):

Xcode is 4.4.1. Running Lion.

I see the following problems. I don't use Java so not familar with how to
fix things...

[WARNING] Some problems were encountered while building the effective model
for nl.lxtreme.ols:org.rxtx:bundle:2.2.0-10
[WARNING] 'dependencies.dependency.systemPath' for
purejavacomm:purejavacomm:jar should not point at files within the project
directory, ${basedir}/purejavacomm.jar will be unresolvable by dependent
projects @ line 39, column 25
[WARNING] 'dependencies.dependency.systemPath' for purejavacomm:jna:jar
should not point at files within the project directory, ${basedir}/jna.jar
will be unresolvable by dependent projects @ line 46, column 25
[WARNING]
[WARNING] It is highly recommended to fix these problems because they
threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support
building such malformed projects.
[WARNING]

...

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-javadoc-plugin:2.7:jar (default) on project
api: MavenReportException: Error while creating archive:Unable to find
javadoc command: The environment variable JAVA_HOME is not correctly set.
-> [Help 1]

What should JAVA_HOME be set to? (You might add a section of steps that
need to be done on the different environments to the REAME).

I also tried running build.sh but it can't find the jars.

[ERROR] No goals have been specified for this build. You must specify a
valid lifecycle phase or a goal in the format : or
:[:]:. Available
lifecycle phases are: validate, initialize, generate-sources,
process-sources, generate-resources, process-resources, compile,
process-classes, generate-test-sources, process-test-sources,
generate-test-resources, process-test-resources, test-compile,
process-test-classes, test, prepare-package, package, pre-integration-test,
integration-test, post-integration-test, verify, install, deploy, pre-site,
site, post-site, site-deploy, pre-clean, clean, post-clean. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/NoGoalSpecifiedException
./build.sh: line 4: cd: ols.distribution/target: No such file or directory
unzip: cannot find or open ols_-full.zip, ols_-full.zip.zip or
ols*-full.zip.ZIP.

No zipfiles found.
rubr (39):

Reply to this email directly or view it on GitHubhttps://github.com/jawi/ols/issues/111#issuecomment-7687391.

Eric B. Decker
Senior (over 50 :-) Researcher

Owner

jawi commented Aug 14, 2012

On http://ols.lxtreme.nl, you only can find the "official" releases. All beta-releases can be found on http://dangerousprototypes.com/forum/viewtopic.php?f=57&t=1198, including DMGs for the latest beta...

I'll write a short howto on setting up an Eclipse environment on the wiki...

Owner

jawi commented Aug 14, 2012

The Wiki page with details on the Eclipse environment can be found here: https://github.com/jawi/ols/wiki/Setting-up-Eclipse

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment