Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

load appropriate ruby-debug for RUBY_VERSION

  • Loading branch information...
commit 75bcacd4aa4b592d7077798533d8ff95df69366f 1 parent 8599d91
@infused infused authored
Showing with 9 additions and 3 deletions.
  1. +9 −3 dbf.gemspec
View
12 dbf.gemspec
@@ -21,8 +21,14 @@ Gem::Specification.new do |s|
s.require_paths = ['lib']
s.required_rubygems_version = '>= 1.3.0'
- s.add_dependency 'fastercsv', '1.5.4'
- s.add_development_dependency 'rspec', '2.6.0'
- # s.add_development_dependency 'metric_fu', '2.0.1'
+ s.add_dependency 'fastercsv', '~> 1.5.4'
+ s.add_development_dependency 'rspec', '~> 2.6.0'
+
+ if RUBY_VERSION.to_f >= 1.9
+ s.add_development_dependency 'ruby-debug19'
+ else
+ s.add_development_dependency 'ruby-debug'
+ end
+ # s.add_development_dependency 'metric_fu'
end
Please sign in to comment.
Something went wrong with that request. Please try again.