Skip to content
Permalink
Browse files

Include main requirements in dev requirements compilation

  • Loading branch information...
jaywink committed Oct 9, 2018
1 parent b4f11f7 commit 9dfb9a02588d7e67fabf22e3cf38d3e06718a65d
Showing with 114 additions and 33 deletions.
  1. +0 −1 dev-requirements.txt
  2. +3 −5 requirements/requirements-dev.in
  3. +111 −27 requirements/requirements-dev.txt
@@ -1,3 +1,2 @@
# Install all locally needed requirements using this
-r requirements/requirements.txt
-r requirements/requirements-dev.txt
@@ -1,3 +1,6 @@
# Include main requirements to avoid conflicts
-r requirements.txt

codecov
coverage
ddt
@@ -6,7 +9,6 @@ django-debug-toolbar-user-panel
django-querycount
django-test-plus<1.1.0 # Some problems running pytest with 1.1.0, figure out why
django_coverage_plugin
django<2.1
factory_boy
Faker
flake8
@@ -26,7 +28,3 @@ Werkzeug

# Recommonmark master has a fix for CommonMark==0.7.3 compatibility which is not released yet
-e git+https://github.com/rtfd/recommonmark.git@c410abb565a3c4ad4de0ce204ab2fa2db8031cf1#egg=recommonmark==0.4.0

# Not a direct requirement, just to match main requirements locked version
# TODO remove once circus is bumped to work with tornado 5.0
tornado<5
@@ -4,60 +4,123 @@
#
# ./compile-requirements.sh
#
-e git+https://github.com/jaywink/django-markdownx.git@bd2fa9dffcbfccc62f9cef2677921537f100bbaa#egg=django-markdownx==2.0.21.1
-e git+https://git.feneas.org/jaywink/federation.git@bc99fe42b49327297f9b69ece18f89ee53236ece#egg=federation==0.18.0-dev.1
-e git+https://github.com/jaywink/pyembed.git@6f8c1cc98d61ee3083e9803255e4b2cc90b5a0dd#egg=pyembed==1.3.3.1
-e git+https://github.com/rtfd/recommonmark.git@c410abb565a3c4ad4de0ce204ab2fa2db8031cf1#egg=recommonmark==0.4.0
alabaster==0.7.11 # via sphinx
argh==0.26.2 # via sphinx-autobuild, watchdog
arrow==0.12.1
asgi-redis==1.4.3
asgiref==1.1.2
atomicwrites==1.1.5 # via pytest
attrs==18.1.0 # via pytest
attrs==18.1.0
autobahn==18.7.1
automat==0.7.0
babel==2.6.0 # via sphinx
backcall==0.1.0 # via ipython
certifi==2018.4.16 # via requests
chardet==3.0.4 # via requests
click==6.7 # via pip-tools
backcall==0.1.0
backports-abc==0.5
beautifulsoup4==4.6.1
bleach==2.1.3
certifi==2018.4.16
channels==1.1.8
chardet==3.0.4
circus==0.15.0
click==6.7
codecov==2.0.15
commonmark==0.7.5
constantly==15.1.0
coreapi==2.3.3
coreschema==0.0.4
coverage==4.5.1
croniter==0.3.25
cssselect==1.0.3
daphne==1.4.2
ddt==1.2.0
decorator==4.3.0 # via ipython, traitlets
decorator==4.3.0
defusedxml==0.5.0
dirty-validators==0.4.0
django-allauth==0.36.0
django-autoslug==1.9.3
django-braces==1.13.0
django-coverage-plugin==1.5.0
django-crispy-forms==1.7.2
django-debug-toolbar-user-panel==1.1.1
django-debug-toolbar==1.9.1
django-dynamic-preferences==1.5.1
django-enumfields==0.10.1
django-environ==0.4.5
django-extensions==2.1.0
django-floppyforms==1.7.0
django-fsm==2.6.0
django-haystack==2.8.1
django-js-reverse==0.8.2
django-memoize==2.1.1
django-model-utils==3.1.2
django-querycount==0.7.0
django-redis==4.9.0
django-rest-swagger==2.2.0
django-reversion==3.0.0
django-robots==3.1.0
django-rq==1.2.0
django-secure==1.0.1
django-settings-export==1.2.1
django-tables2==1.21.2
django-test-plus==1.0.22
django-versatileimagefield==1.9
django==2.0.8
djangorestframework==3.8.2
docutils==0.14 # via sphinx
factory-boy==2.11.1
faker==0.8.17
first==2.0.1 # via pip-tools
flake8==3.5.0
freezegun==0.3.10
future==0.16.0 # via commonmark
future==0.16.0
gprof2dot==2017.9.19 # via pytest-profiling
idna==2.7 # via requests
html5lib==1.0.1
hyperlink==18.0.0
idna==2.7
imagesize==1.0.0 # via sphinx
incremental==17.5.0
ipdata==2.6
ipdb==0.11
ipython-genutils==0.2.0 # via traitlets
ipython==6.5.0 # via ipdb
jedi==0.12.1 # via ipython
jinja2==2.10 # via sphinx
ipython-genutils==0.2.0
ipython==6.5.0
isodate==0.6.0
itypes==1.1.0
jedi==0.12.1
jinja2==2.10
jsonschema==2.6.0
livereload==2.5.2 # via sphinx-autobuild
markupsafe==1.0 # via jinja2
lxml==4.2.2
markdown==2.6.11
markupsafe==1.0
mccabe==0.6.1 # via flake8
more-itertools==4.3.0 # via pytest
msgpack-python==0.5.6
oauthlib==2.1.0
openapi-codec==1.3.2
packaging==17.1 # via sphinx
parso==0.3.1 # via jedi
parso==0.3.1
pathtools==0.1.2 # via sphinx-autobuild, watchdog
pexpect==4.6.0 # via ipython
pickleshare==0.7.4 # via ipython
persisting-theory==0.2.1
pexpect==4.6.0
pickleshare==0.7.4
pillow==5.0.0
pip-tools==2.0.2
pluggy==0.7.1 # via pytest
port-for==0.3.1 # via sphinx-autobuild
prompt-toolkit==1.0.15 # via ipython
ptyprocess==0.6.0 # via pexpect
prompt-toolkit==1.0.15
psutil==5.4.6
psycopg2-binary==2.7.5
ptyprocess==0.6.0
py==1.5.4 # via pytest
pycodestyle==2.3.1 # via flake8
pycryptodome==3.6.6
pyflakes==1.6.0 # via flake8
pygments==2.2.0 # via ipython, sphinx
pygments==2.2.0
pyhamcrest==1.9.0
pyparsing==2.2.0 # via packaging
pytest-blockage==0.2.0
pytest-cov==2.5.1
@@ -66,12 +129,22 @@ pytest-env==0.6.2
pytest-profiling==1.3.0
pytest-sugar==0.9.1
pytest==3.7.1
python-dateutil==2.7.3 # via faker, freezegun
pytz==2018.5 # via babel, django
python-dateutil==2.7.3
python-opengraph-jaywink==0.2.0
python-xrd==0.1
python3-openid==3.1.0
pytz==2018.5
pyyaml==3.13 # via sphinx-autobuild, watchdog
requests==2.19.1 # via codecov, sphinx
simplegeneric==0.8.1 # via ipython
six==1.11.0 # via django-coverage-plugin, faker, freezegun, livereload, more-itertools, packaging, pip-tools, prompt-toolkit, pytest, pytest-profiling, python-dateutil, sphinx, traitlets
pyzmq==16.0.4
raven==6.9.0
redis==2.10.6
requests-oauthlib==1.0.0
requests==2.19.1
rq-scheduler==0.8.3
rq==0.12.0
simplegeneric==0.8.1
simplejson==3.16.0
six==1.11.0
snowballstemmer==1.2.1 # via sphinx
sphinx-autobuild==0.7.1
sphinx==1.7.6
@@ -80,8 +153,19 @@ sqlparse==0.2.4 # via django-debug-toolbar
termcolor==1.1.0 # via pytest-sugar
text-unidecode==1.2 # via faker
tornado==4.5.3
traitlets==4.3.2 # via ipython
urllib3==1.23 # via requests
traitlets==4.3.2
twisted==18.7.0
txaio==18.7.1
typing==3.6.4
unicode-slugify==0.1.3
unidecode==1.0.22
uritemplate==3.0.0
urllib3==1.23
uwsgi==2.0.17.1
watchdog==0.8.3 # via sphinx-autobuild
wcwidth==0.1.7 # via prompt-toolkit
wcwidth==0.1.7
webencodings==0.5.1
werkzeug==0.14.1
whitenoise==4.0
whoosh==2.7.4
zope.interface==4.5.0

0 comments on commit 9dfb9a0

Please sign in to comment.
You can’t perform that action at this time.