New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add support for Django 1.11, dev #629

Merged
merged 3 commits into from May 25, 2017

Conversation

Projects
None yet
2 participants
@jwhitlock
Contributor

jwhitlock commented May 24, 2017

Alternate to PR #628 that keeps Django 1.6 and 1.7 support.

  • Use new urlpattern syntax
  • Switch .travis.yml to matrix form, to specify specific Python versions
  • Remove invalid docsinstall and double install from .travis.yml
  • Add Django 1.11 and master (allowed failure) targets, and Python 3.6
  • Add doc target to .travis.yml
Add support for Django 1.11, dev
- Use new urlpattern syntax
- Switch .travis.yml to matrix form, to specify specific Python versions
- Remove invalid docsinstall and double install from .travis.yml
- Add Django 1.11 and master (allowed failure) targets, and Python 3.6
- Add doc target to .travis.yml
@coveralls

This comment has been minimized.

coveralls commented May 24, 2017

Coverage Status

Changes Unknown when pulling 5ef277b on jwhitlock:django-110-add-only into ** on jazzband:master**.

@jwhitlock

This comment has been minimized.

Contributor

jwhitlock commented May 24, 2017

I think I can get the master branch passing on pypy3 2.4.0 (python 3.5.3 compat) instead of pypy 2.5.0 (2.7.13 compat)

@coveralls

This comment has been minimized.

coveralls commented May 25, 2017

Coverage Status

Changes Unknown when pulling 641b762 on jwhitlock:django-110-add-only into ** on jazzband:master**.

Remove pypy target from master
pypy is 2.5.0, which is compatible with Python 2.7.13.
pypy3 is 2.4.0, which is compatible with Python 3.2, and won't work with
pip.
@jwhitlock

This comment has been minimized.

Contributor

jwhitlock commented May 25, 2017

Nope. pypy3 installs PyPy3 2.4, which is compatible with Python 3.2.5, and is no longer supported by virtualenv and install tools. We'll have to wait until PyPy 5.7.1 or similar is supported by TravisCI, such as travis-ci/travis-ci#7507.

@coveralls

This comment has been minimized.

coveralls commented May 25, 2017

Coverage Status

Changes Unknown when pulling f64af81 on jwhitlock:django-110-add-only into ** on jazzband:master**.

@jwhitlock

This comment has been minimized.

Contributor

jwhitlock commented May 25, 2017

This still looks good, so I'm merging. There were no changes to the pipeline code to support 1.11 and master - just updates to the test code.

@jwhitlock jwhitlock merged commit bb9de3c into jazzband:master May 25, 2017

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls First build on master at 82.133%
Details

@jwhitlock jwhitlock deleted the jwhitlock:django-110-add-only branch May 25, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment