Permalink
Browse files

Adding a version check for Ruby 1.8.6.

Other versions (1.8.7, <1.8.6, and esp. 1.9) explode at the moment.
  • Loading branch information...
1 parent 765121e commit 7d82c26996783b0599576734e41c35f0f8d90a58 @jbarnette committed Nov 10, 2008
Showing with 2 additions and 0 deletions.
  1. +2 −0 Rakefile
View
@@ -3,6 +3,8 @@ require "erb"
require "./lib/hoe.rb"
require "./lib/johnson/version.rb"
+abort "Need Ruby version 1.8.6!" unless RUBY_VERSION == "1.8.6"
+
# what sort of extension are we building?
kind = Config::CONFIG["DLEXT"]

0 comments on commit 7d82c26

Please sign in to comment.