Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Hey, let's see if we can have a working version, huh?

  • Loading branch information...
commit 8da36c71fbd991cbaddf65e53c07fb6fbfa76c7a 1 parent c2fd4dc
John Barnette authored
2  README.rdoc
View
@@ -24,7 +24,7 @@ Broadcast standard out using Bonjour.
alice-monkeys
# Copy the clipboard contents from one machine to another
- alice$ pbpaste | pastejour
+ alice$ pbpaste | pastejour bob
bob$ pastejour | pbcopy
== ORLY?
2  bin/pastejour
View
@@ -1,6 +1,6 @@
#!/usr/bin/env ruby
-require "rubygems"
+$:.unshift(File.expand_path(File.join(File.dirname(__FILE__), "..", "lib")))
require "pastejour"
multiple = ARGV.delete("-m")
1  lib/pastejour.rb
View
@@ -1,3 +1,4 @@
+require "rubygems"
require "dnssd"
require "set"
require "socket"
4 lib/pastejour/version.rb
View
@@ -1,5 +1,3 @@
module Pastejour
- major, minor, tiny = 1, 0, 0
- nano = ENV['RELEASE'] ? nil : Time.now.strftime("%Y%m%d%H%M")
- VERSION = [major, minor, tiny, nano].compact.join('.').freeze
+ VERSION = "1.0.5".freeze
end
10 pastejour.gemspec
View
@@ -1,11 +1,13 @@
+# -*- encoding: utf-8 -*-
+
Gem::Specification.new do |s|
s.name = %q{pastejour}
- s.version = "1.0.0.200808041733"
+ s.version = "1.0.5"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["John Barnette", "Evan Phoenix"]
s.autorequire = %q{pastejour}
- s.date = %q{2008-08-04}
+ s.date = %q{2008-11-24}
s.default_executable = %q{pastejour}
s.description = %q{Broadcast standard out.}
s.email = %q{jbarnette@rubyforge.org}
@@ -15,14 +17,14 @@ Gem::Specification.new do |s|
s.has_rdoc = true
s.homepage = %q{http://github.com/jbarnette/pastejour}
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.2.0}
+ s.rubygems_version = %q{1.3.0}
s.summary = %q{Broadcast standard out.}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 2
- if current_version >= 3 then
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<dnssd>, [">= 0.6.0"])
else
s.add_dependency(%q<dnssd>, [">= 0.6.0"])
Please sign in to comment.
Something went wrong with that request. Please try again.