Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

bump versions to M7. Note the various IUs that have vanished since M6. Also need to bump to Mars M7 but the mirror is still in progress. >> 4.50.x #142

Merged
merged 1 commit into from May 21, 2015

Conversation

@nickboldt
Copy link
Member

commented May 6, 2015

No description provided.

@mickaelistria

This comment has been minimized.

Copy link
Member

commented May 7, 2015

Can you please create a Jira and attach a p2diff?

@nickboldt nickboldt force-pushed the nickboldt:move-to-M7 branch 3 times, most recently from acbaf2e to 94d7668 May 7, 2015

@nickboldt

This comment has been minimized.

Copy link
Member Author

commented May 7, 2015

@nickboldt nickboldt force-pushed the nickboldt:move-to-M7 branch 2 times, most recently from e226242 to b4e006e May 7, 2015

@mickaelistria

This comment has been minimized.

Copy link
Member

commented May 8, 2015

I didn't get too much into details, but from a high-level perspective, this change looks good and I can't think of anything else to do in order to adopt M7.

@nickboldt nickboldt force-pushed the nickboldt:move-to-M7 branch 2 times, most recently from 16fc3d5 to 256b5ed May 11, 2015

bump versions to M7. Note the various IUs that have vanished since M6.
remove fest (commented out anyway)

add org.eclipse.tm.terminal.control.feature.feature.group (rse.terminals requires it); remove old org.junit 3.8.2.v3_8_2_v20130308-0410

add org.eclipse.egit.ui.importer 0.0.1.201505070847 (found it in nightly egit site)

jbosstools-server requires org.eclipse.tm.terminal

instead of org.eclipse.tm.terminal, add org.eclipse.tm.terminal.* and reqs from eclipse platform and CDT... is this good?

remove connector.local.feature and org.eclipse.cdt.core.* deps to see if we really need them

connector.local requires cdt.native (JBIDE-17686, JBIDE-19776), and by adding the feature we work around the platform-specific fragments which fail validation

use Locus 1.2.0.Final version of Mockito 1.9.5.v20131024-0922

@nickboldt nickboldt force-pushed the nickboldt:move-to-M7 branch from 256b5ed to da4aeb2 May 14, 2015

@nickboldt nickboldt merged commit da4aeb2 into jbosstools:4.50.x May 21, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.