Browse files

Update build settings and requirements

* uses tycho 0.15.0
* test plugin now requires m2e-wtp 0.16 from eclipse.org (yet uses the
CI build from JBoss server)
* increased m2e compat. version range to [1.0.0,2.0.0)
  • Loading branch information...
1 parent 930c970 commit 30aa4a65bfe0f8ccd0f75d0c7e084eb02e79e44e @fbricon fbricon committed Aug 17, 2012
Showing with 5 additions and 5 deletions.
  1. +3 −3 org.jboss.tools.m2e.wro4j.tests/META-INF/MANIFEST.MF
  2. +2 −2 pom.xml
View
6 org.jboss.tools.m2e.wro4j.tests/META-INF/MANIFEST.MF
@@ -4,12 +4,12 @@ Bundle-Name: WRO4J Tests Plug-in
Bundle-SymbolicName: org.jboss.tools.m2e.wro4j.tests
Bundle-Version: 1.0.1.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6, JavaSE-1.7
-Require-Bundle: org.eclipse.m2e.tests.common;bundle-version="[1.0.0,1.2.0)",
+Require-Bundle: org.eclipse.m2e.tests.common;bundle-version="[1.0.0,2.0.0)",
org.junit;bundle-version="3.8.2",
- org.eclipse.m2e.core;bundle-version="[1.0.0,1.2.0)",
+ org.eclipse.m2e.core;bundle-version="[1.0.0,2.0.0)",
org.eclipse.core.resources;bundle-version="3.4.2",
org.eclipse.core.runtime;bundle-version="3.4.0",
org.eclipse.jdt.core;bundle-version="3.4.4",
org.jboss.tools.m2e.wro4j.core,
- org.maven.ide.eclipse.wtp;bundle-version="[0.14.0,1.0)"
+ org.eclipse.m2e.wtp;bundle-version="0.16.0"
Bundle-Vendor: Red Hat, Inc.
View
4 pom.xml
@@ -22,7 +22,7 @@
<packaging>pom</packaging>
<name>M2E connector for WRO4J :: Parent </name>
<properties>
- <tycho-version>0.14.1</tycho-version>
+ <tycho-version>0.15.0</tycho-version>
<test.timeout>600</test.timeout><!-- 10 mins -->
<tycho.test.jvmArgs>-Xmx512m -XX:MaxPermSize=256m</tycho.test.jvmArgs>
</properties>
@@ -56,7 +56,7 @@
<repository>
<id>m2e-wtp</id>
<layout>p2</layout>
- <url>http://download.jboss.org/jbosstools/updates/m2eclipse-wtp/</url>
+ <url>http://download.jboss.org/jbosstools/updates/requirements/m2eclipse/m2e-wtp-juno/</url>
</repository>
</repositories>

0 comments on commit 30aa4a6

Please sign in to comment.