New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

init.rb - config values not taken #246

Closed
nicesw123 opened this Issue Jul 28, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@nicesw123

nicesw123 commented Jul 28, 2014

Dear all, dear Nicolas

I'm using v0.7.6 and see strange behaviour with init.rb:

some init.rb-config-values are not taken on normal redmine:plugins:migrate

Not all values of init.rb are taking during normal installation (RAILS_ENV=production NAME=redmine_git_hosting rake redmine:plugins:migrate):

Example: the values of

  • :download_revision_enabled
  • :show_repositories_url

are not taken.

Documentation-Bug:

Here configuration/notes/#resynchronization-of-gitolite-configuration we can read:

      To restore/update your plugin settings, set you current settings in init.rb file, then execute:

...
redmine$ RAILS_ENV=production rake redmine_git_hosting:restore_default_settings

This does not work: redmine_git_hosting:restore_default_settings

Instead use:                redmine_git_hosting:restore_defaults

some init.rb-config-values are not taken on redmine_git_hosting:restore_defaults

Even when explicitly running

RAILS_ENV=production rake redmine_git_hosting:restore_defaults

some values are not taken:

  • :gitolite_hooks_debug
  • :download_revision_enabled

Thanks so much for Redmine Git Hosting!!! Best Redmine plugin! ;)

@n-rodriguez n-rodriguez self-assigned this Jul 31, 2014

@n-rodriguez

This comment has been minimized.

Show comment
Hide comment
@n-rodriguez

n-rodriguez Sep 18, 2014

Member

This does not work: redmine_git_hosting:restore_default_settings

Instead use: redmine_git_hosting:restore_defaults

Yes. The task has been renamed in v0.8 to be more explicit.
So :

  • v0.8 : redmine_git_hosting:restore_default_settings
  • v0.7 : redmine_git_hosting:restore_defaults
Member

n-rodriguez commented Sep 18, 2014

This does not work: redmine_git_hosting:restore_default_settings

Instead use: redmine_git_hosting:restore_defaults

Yes. The task has been renamed in v0.8 to be more explicit.
So :

  • v0.8 : redmine_git_hosting:restore_default_settings
  • v0.7 : redmine_git_hosting:restore_defaults
@n-rodriguez

This comment has been minimized.

Show comment
Hide comment
@n-rodriguez

n-rodriguez Sep 18, 2014

Member

Not all values of init.rb are taking during normal installation (RAILS_ENV=production NAME=redmine_git_hosting rake redmine:plugins:migrate):

It's normal, they don't come from here. When you're doing redmine:plugins:migrate values are taken from existing installation or set to default (default value is hardcoded in migration file).

Member

n-rodriguez commented Sep 18, 2014

Not all values of init.rb are taking during normal installation (RAILS_ENV=production NAME=redmine_git_hosting rake redmine:plugins:migrate):

It's normal, they don't come from here. When you're doing redmine:plugins:migrate values are taken from existing installation or set to default (default value is hardcoded in migration file).

@n-rodriguez n-rodriguez added the bug label Sep 18, 2014

n-rodriguez added a commit that referenced this issue Sep 18, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment