Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update installation instructions with corrections.

  • Loading branch information...
commit e84fa15d7718ac50b6d8b3250c065768ccf0353b 1 parent 0c7ca27
@JDutil JDutil authored
View
4 Gemfile
@@ -1,7 +1,3 @@
source 'http://rubygems.org'
-group :test do
- gem 'ffaker'
-end
-
gemspec
View
10 README.md
@@ -14,7 +14,7 @@ I make the assumption that you have a functioning Spree store and are just exten
Add spree_sunspot_search to your Gemfile and run bundler.
```ruby
-gem 'spree_sunspot_search', git: 'git://github.com/jbrien/spree_sunspot_search.git'
+gem 'spree_sunspot', github: 'jbrien/spree_sunspot_search'
```
add the following to the Gemfile if you are not using another solr install locally for testing and development. The rake tasks for starting and stop this for development are included automatically for your use.
@@ -25,14 +25,10 @@ group :test, :development do
end
```
-Install the solr.yml file from Sunspot.
+Install the sunspot.yml file from Sunspot and the spree_sunspot and spree_sunspot_filters initializers.
```ruby
-rails g sunspot_rails:install
-```
-
-```ruby
-rails g spree_sunspot_search:install
+rails g spree:sunspot:install
```
Running
View
1  Versionfile
@@ -1,2 +1,3 @@
"0.7.0" => { :ref => "dbeb34c149c7d7ecc3f94820e0ae4a9e4798e13a" }
"1.1.x" => { :branch => "spree-1.1" }
+"1.2.x" => { :branch => "master" }
View
1  lib/generators/spree/sunspot/install/install_generator.rb
@@ -5,6 +5,7 @@
module Spree::Sunspot
module Generators
class InstallGenerator < Rails::Generators::Base
+
def self.source_root
@source_root ||= File.expand_path(File.join(File.dirname(__FILE__), 'templates'))
end
View
2  lib/spree/sunspot/engine.rb
@@ -5,6 +5,8 @@
module Spree
module Sunspot
class Engine < Rails::Engine
+ require 'spree/core'
+ isolate_namespace Spree
engine_name 'spree_sunspot'
config.autoload_paths += %W(#{config.root}/lib)
View
8 script/rails
@@ -1,5 +1,7 @@
-#!/usr/bin/env ruby
# This command will automatically be run when you run "rails" with Rails 3 gems installed from the root of your application.
-ENGINE_PATH = File.expand_path('../..', __FILE__)
-load File.expand_path('../../spec/dummy/script/rails', __FILE__)
+ENGINE_ROOT = File.expand_path('../..', __FILE__)
+ENGINE_PATH = File.expand_path('../../lib/spree_sunspot/engine', __FILE__)
+
+require 'rails/all'
+require 'rails/engine/commands'
View
1  spec/spec_helper.rb
@@ -4,6 +4,7 @@
require File.expand_path("../dummy/config/environment.rb", __FILE__)
require 'rspec/rails'
+require 'ffaker'
# Requires supporting ruby files with custom matchers and macros, etc,
# in spec/support/ and its subdirectories.
Please sign in to comment.
Something went wrong with that request. Please try again.