Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Default strategy doesn't find .NET core assemblies #2

Closed
daveriedstra opened this issue Feb 1, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@daveriedstra
Copy link

commented Feb 1, 2017

Without providing the assemblies property in tgconfig.json, TypeGen ProjectFolder outputs the following error:

GENERIC ERROR: Value cannot be null.
Parameter name: assemblyFile

Adding "bin/Debug/netcoreapp1.[x]/[ProjectName].dll" to assemblies resolves this. I don't think our project is configured exceptionally. Maybe the default strategy should look there for assemblies?

Project is .NET core 1.1 using VS2015.

@jburzynski

This comment has been minimized.

Copy link
Owner

commented Feb 1, 2017

Yes, it's a bug - the search works for .NET Framework, but for .NET Core it searches wrong folders. Will be fixed in the next release.

@jburzynski

This comment has been minimized.

Copy link
Owner

commented Feb 7, 2017

Resolved in 1.5.1. Leaving this open in case there are some issues (will close if there are none).

@jburzynski jburzynski closed this Feb 13, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.