Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

v0.8.6

Bump to 0.8.6 for connect_to_master => connect.

v0.8.5

Bump 0.8.5. Just a plucky update.

v0.8.3

Release 0.8.3. Tiny bugs.

v0.8.2

Release 0.8.2. Fixes issue with one embedded doc being nil.

v0.8.1

Release 0.8.1.
* Added ability to use class scopes on many document associations
* Added sexy querying to many document associations (where, limit, sort, etc)
* Updated plucky version

v0.8.0

Release 0.8.0.
Highlights:

  * Sexy query language ie: Foo.where(...).sort(...).limit(...)
  * Scopes. ie: scope :published, lambda { where(:published_at.lte => Time.now.utc) }
  * Accessible plugin that works like attr_accessible in Rails.
  * Cache key method to make caching easier.
  * Plucky and Ruby driver upgrades
  * New option :typecast for Array keys ie: key :user_ids, Array, :typecast => 'ObjectId'
  * Far more obvious about core extensions. Now live in lib/mongo_mapper/extensions and are included in ancestors instead of just opening core classes.
  * Added an UPGRADES file which will denote backwards compat breaking from now on.
  * A bajillion little bug fixes and improvements.

v0.7.6

Release 0.7.6.
* Documents now load from database using write_key instead of public accessors which allows you to update public accessor and not affect querying/loading from the db
* Document.set now typecasts values before performing the set
* Times at the end of a month no longer round up. Milliseconds are now removed from times.
* Float.to_mongo(nil) now returns nil.
* MongoMapper::Query is now powered by Plucky. Deeper Plucky integration is slated for next release.
* Custom gemspec/rake tasks instead of jeweler. More simple.

v0.7.5

Regenerated gemspec for version 0.7.5

v0.7.4

Regenerated gemspec for version 0.7.4
Something went wrong with that request. Please try again.