Show a problem with rails 2.3.14, rspec 1.3.2 and plugins
Ruby JavaScript
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
.idea
app
config
db
doc
public
script
test
vendor/plugins/rails_history
.gitignore
Gemfile
Gemfile.lock
README
Rakefile

README

This app is a stock Rails 2.3.14 app, with Bundler installed
according to: http://gembundler.com/rails23.html

It's Gemfile contain a minimal set of gems (but also RSpec / Cucumber)
for the tests.

In addition, there is one plugin "rails_history" - inherited from a really
old, Rails 1.2.3 project.

Problem Description
-------------------

If Rspec is specified in the Gemfile (as it is when checked in), the app
doesn't run and dies because the "history" keyword (which is provided by the
plugin) isn't loaded.

Disabling RSpec (by removing the :development group), makes the app start just
fine