Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Package for 0.11.1 release

  • Loading branch information...
commit f79f8332af6eaf4e21eb5734d500d938b70be40c 1 parent eeb497c
@jcrosby authored
View
7 CHANGES
@@ -1,3 +1,10 @@
+0.11.1
+- Added a block option for configuring OpenID bypassed routes (Devlin Daley)
+- Added write locks for Tokyo Tyrant Tables
+- Added Tokyo Tyrant Table example
+- Fixed POST method tunneling bug (Saimon Moore)
+- Fixed escaping of nested JSON Objects and Arrays
+
0.11.0
- Added Tokyo Cabinet storage
- Added MemoryTable development-time storage
View
5 cloudkit.gemspec
@@ -2,8 +2,8 @@ Gem::Specification.new do |s|
s.specification_version = 2 if s.respond_to? :specification_version=
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.name = "cloudkit"
- s.version = "0.11.0"
- s.date = "2008-03-09"
+ s.version = "0.11.1"
+ s.date = "2008-03-24"
s.summary = "An Open Web JSON Appliance."
s.description = "An Open Web JSON Appliance."
s.authors = ["Jon Crosby"]
@@ -29,6 +29,7 @@ Gem::Specification.new do |s|
examples/3.ru
examples/4.ru
examples/5.ru
+ examples/6.ru
examples/TOC
lib/cloudkit.rb
lib/cloudkit/constants.rb
View
6 doc/curl.html
@@ -38,13 +38,13 @@
</p>
<p>
-If you already have the gem, make sure you're running the latest version (0.11.0):
+If you already have the gem, make sure you're running the latest version (0.11.1):
<div class="code">
$ gem list cloudkit<br/>
- cloudkit (0.9.1) &lt;-- need to upgrade<br/>
+ cloudkit (0.10.0) &lt;-- need to upgrade<br/>
$ gem update cloudkit<br/>
$ gem list cloudkit<br/>
- cloudkit (0.11.0, 0.9.1) &lt;-- 0.11.0 is now in the list
+ cloudkit (0.11.1, 0.10.0) &lt;-- 0.11.1 is now in the list
</div>
</p>
View
2  doc/index.html
@@ -24,7 +24,7 @@
</div>
<div class="meta">
<p class="wrapper">
- Version 0.11 released with Tokyo Cabinet support. Install with <em>gem install cloudkit</em>.
+ Version 0.11.1 released with Tokyo Cabinet support. Install with <em>gem install cloudkit</em>.
</p>
</div>
<div class="wrapper intro-row">
View
4 lib/cloudkit.rb
@@ -34,11 +34,11 @@
include CloudKit::Constants
module CloudKit
- VERSION = '0.11.0'
+ VERSION = '0.11.1'
# Sets up the storage adapter. Defaults to development-time
# CloudKit::MemoryTable. Also supports Rufus Tokyo Table instances. See the
- # examples directory for a demonstration.
+ # examples directory for Cabinet and Tyrant Table examples.
def self.setup_storage_adapter(adapter_instance=nil)
@storage_adapter = adapter_instance || CloudKit::MemoryTable.new
end
View
3  spec/openid_filter_spec.rb
@@ -21,7 +21,7 @@
response = @request.get('/foo')
response.status.should == 200
end
-
+
it "should allow pass through of URIs defined in bypass route callback" do
openid_app = Rack::Builder.new {
use Rack::Lint
@@ -75,4 +75,5 @@
end
end
+
end
Please sign in to comment.
Something went wrong with that request. Please try again.