Assets 7

This is the release of JDemetra+ 2.2.1.
Java SE 8 or later version is required to run it.

Release notes

Statistical Algorithms

  • [FIXED] Bug in derived results of the canonical decomposition (SEATS)
  • [FIXED] Correction in D16, D18 (X11)
  • [ADDED] Possibility to fix some coefficients in trading days variables
  • [ADDED] Definition of the forecast horizon (SEATS)
  • [ADDED] Pseudo-additive decomposition in X11

I/O

  • [FIXED] XXE vulnerability

Graphical user interface

  • [FIXED] Java 9 compatibility (JNA, chart rendering, launch)
  • [FIXED] Html styling & rendering
  • [IMPROVED] Zoom in html pages
Pre-release

@charphi charphi released this Apr 6, 2018

Assets 3

This is the release candidate 2 of JDemetra+ 2.2.1.
Java SE 8 or later version is required to run it.

Pre-release

@charphi charphi released this Mar 9, 2018

Assets 3

This is the release candidate 1 of JDemetra+ 2.2.1.
Java SE 8 or later version is required to run it.

@charphi charphi released this Jul 11, 2017 · 31 commits to master since this release

Assets 7

This is the release of JDemetra+ 2.2.0.
Java SE 8 or later version is required to run it.

Release notes

Statistical Algorithms

  • [FIXED] Wrong degrees of freedom in LjungBox (diagnostics)
  • [FIXED] Julian Easter dates
  • [IMPROVED] Re-estimation of RegArima models (performance/precision issues)
  • [ADDED] Gamma distribution (+used in other distributions)
  • [ADDED] Fixed regression coefficients
  • [ADDED] Canova-Hansen and (augmented) Dickey-Fuller tests
  • [FIXED] Wrong canonical decomposition in case of complex models
  • [FIXED] Benchmarking in case of incomplete starting year
  • [FIXED] Small bugs in X11 (advanced cases)
  • [FIXED] Bug in RegArima forecasts (NaN) in case of missing values in the first obs.
  • [IMPROVED] New factorization of the autocovariance function (SEATS). More robust.
  • [ADDED] Analysis of the revisions of SA changes
  • [ADDED] Trading days: derived Sunday effect
  • [ADDED] Backcasts in X11

I/O

  • [IMPROVED] TsProviders API
  • [ADDED] TCK (technical compatibility kit) for TsProviders
  • [IMPROVED] Parsing of Excel files
  • [FIXED] Bugs in xml files (Tramo/regarima)
  • [ADDED] New xml schema (to be used in WEB services)
  • [ADDED] Wild cards in results retrieval
  • [ADDED] Dynamic results retrieval (extension by plug-ins)

Graphical user interface

  • [ADDED] Fixed regression coefficients (editors to modify them)
  • [ADDED] Add ability to set comments on specifications, documents
  • [FIXED] 3D likelihood chart bug fix when there are no parameters
  • [IMPROVED] SI ratio chart : easier to select and identify observations
  • [IMPROVED] User can now select between 2 editors for prespecified outliers (in the options)
  • [ADDED] Import/export of specifications from/to the workspace
  • [ADDED] Copy of results from the Check Last anomaly detection
  • [ADDED] Export of results components from a SA processing
  • [ADDED] Custom matrix of diagnostics
  • [IMPROVED] Drag & Drop feedback
  • [IMPROVED] Error reporting in auto-completion
  • [IMPROVED] Propertysheet layout when editing beans
  • [ADDED] Saving of Ts to text files
  • [FIXED] Default working dir of workspace
  • [FIXED] Fixed dot/comma mismatch in numeric editors
  • [FIXED] Commit behavior of Day editor
  • [ADDED] New forecasts/backcasts panel (TODO)

Other

  • [ADDED] JRE 8 minimum requirement to run the application
  • [ADDED] Maven snapshots repository
  • [IMPROVED] jwsacruncher moved to its own repository
  • [ADDED] WEB services around JD+
  • [ADDED] Light R package
Pre-release

@charphi charphi released this Jul 3, 2017

Assets 3

This is the release candidate 4 of JDemetra+ 2.2.0.
Java SE 8 or later version is required to run JDemetra+.

Pre-release

@charphi charphi released this Jun 7, 2017

Assets 3

This is the release candidate 3 of JDemetra+ 2.2.0.
Java SE 8 or later version is required to run JDemetra+.

Pre-release

@charphi charphi released this May 17, 2017

Assets 3

This is the release candidate 2 of JDemetra+ 2.2.0.
Java SE 8 or later version is required to run JDemetra+.

Pre-release

@charphi charphi released this Mar 31, 2017

Assets 3

This is the release candidate 1 of JDemetra+ 2.2.0.
Java SE 8 or later version is required to run JDemetra+.

Pre-release

@charphi charphi released this Mar 23, 2016

Assets 3

This is the release candidate 4 of JDemetra+ 2.1.0.
Java SE 7 or later version is required to run JDemetra+.