Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Howto: build processing-py.jar? #96

Closed
tildebyte opened this issue Jun 24, 2014 · 8 comments

Comments

Projects
None yet
3 participants
@tildebyte
Copy link
Contributor

commented Jun 24, 2014

I've poked around in the build.xml, but I don't see anything that looks like it will build processing-py.jar by itself. I can handle updating the Processing elements by hand (I don't usually need to rebuild it, and it's only a few files), but building the jar manually is a pain.

@jdf

This comment has been minimized.

Copy link
Owner

commented Jun 24, 2014

$ ant jar

@jdf jdf closed this Jun 24, 2014

@tildebyte

This comment has been minimized.

Copy link
Contributor Author

commented Jun 24, 2014

Derp. Thanks.

@tildebyte

This comment has been minimized.

Copy link
Contributor Author

commented Jun 24, 2014

Shoot. It still wants to build all of Processing/PDE/processing-video, possibly more - I don't know 'cause I'm getting an error in the (I think) PDE.

@jdf

This comment has been minimized.

Copy link
Owner

commented Jun 24, 2014

Yes, it has to build everything. After having done so once, it still has to check everything to see what needs to be rebuilt, but won't actually do the compile.

@tildebyte

This comment has been minimized.

Copy link
Contributor Author

commented Jun 24, 2014

Understood.

@kazimuth

This comment has been minimized.

Copy link
Contributor

commented Jun 24, 2014

Make sure you tell ant where the processing and processing-video repositories are, if they're not next to processing.py.

@tildebyte

This comment has been minimized.

Copy link
Contributor Author

commented Jun 24, 2014

Right. Done. It's building with 100% less whinging, however I'm still getting the path weirdness from #95.

@kazimuth

This comment has been minimized.

Copy link
Contributor

commented Jun 25, 2014

Could you make a new issue for that?
I should have a windows machine I can solve it on tomorrow.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.