Skip to content

problem with importing #21

Open
dsay opened this Issue Mar 26, 2012 · 1 comment

2 participants

@dsay
dsay commented Mar 26, 2012

If I add oauthconsumer a project to get errors in NSZone NSObject
what could be the problem ???

@FiveFlamesMobile

I'm also having problems when importing OAuthConsumer into my project, I'm unable to compile the project due to "Undefined symbols not found" using XCode 4.3.2.

Undefined symbols for architecture armv7:
"OBJC_CLASS$OAConsumer", referenced from:
objc-class-ref in GSTwitPicEngine.o
objc-class-ref in SA_OAuthTwitterEngine.o
objc-class-ref in Foursquare.o
"_OBJC_CLASS
$OARequestParameter", referenced from:
objc-class-ref in OARequestHeader.o
objc-class-ref in SA_OAuthTwitterEngine.o
objc-class-ref in Foursquare.o
"_OBJC_CLASS
$OAMutableURLRequest", referenced from:
objc-class-ref in SA_OAuthTwitterEngine.o
objc-class-ref in Foursquare.o
"_OBJC_CLASS
$OAHMAC_SHA1SignatureProvider", referenced from:
objc-class-ref in OARequestHeader.o
"_OBJC_CLASS
$OAToken", referenced from:
objc-class-ref in SA_OAuthTwitterEngine.o
objc-class-ref in Foursquare.o
"_OBJC_CLASS
$_OADataFetcher", referenced from:
objc-class-ref in SA_OAuthTwitterEngine.o
ld: symbol(s) not found for architecture armv7
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Could someone help me?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.