Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

PyPI version outdated. Same version as repo, but older code #119

Open
thetylerhayes opened this Issue Sep 8, 2013 · 3 comments

Comments

Projects
None yet
3 participants

PyPI currently lists Ghost.py versoin 0.1b2 as the most recent, which is also what setup.py in this repo currently lists as the current version number.

But I just ran pip install Ghost.py and it's definitely not the latest or even near the latest code.

Case in point, in shell I ran:

from ghost import Ghost
ghost = Ghost()

And the response was Exception: Xvfb is required to a ghost run oustside an X instance. Notice specifically the extra s in oustside. That error message was updated 6 months ago: 1dfe637.

So it seems ike the current PyPI version is at least 6 months old.

PS: To anyone else who runs into this before it's fixed you can address this by simply cloning the repo (in a path like /path/to/python/lib/python2.7/site-packages/), running python setup.py build, and then python setup.py install. Make sure you've run pip uninstall Ghost.py first if you've already tried installing via pip.

@ghost

ghost commented Dec 12, 2013

this worked for me as well.

I have occurred the same error when if ssh the server and 'ghost.Ghost()', but if i do it on ubuntu desktop, the error is disappear.
Is there some way to use it on ssh (below no windows)?

I had same issue on Ubuntu with ssh. The issue was actuall Xvfb was not installed. I installed that through apt-get install xvfb and issue disappeared.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment