Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 39 lines (32 sloc) 1.406 kb
e86ac31 @jedi4ever first attempt to create vagrant plugin + gem
authored
1 # -*- encoding: utf-8 -*-
2 require File.expand_path("../lib/veewee/version", __FILE__)
3
4 Gem::Specification.new do |s|
5 s.name = "veewee"
6 s.version = Veewee::VERSION
7 s.platform = Gem::Platform::RUBY
8 s.authors = ["Patrick Debois", "Ringo De Smet"]
e231bf2 @jedi4ever made ostypes work
authored
9 s.email = ["patrick.debois@jedi.be", "ringo.desmet@gmail.com"]
10 s.homepage = "http://github.com/jedi4ever/veewee/"
11 s.summary = %q{Vagrant box creation}
12 s.description = %q{Expand the 'vagrant box' command to support the creation of base boxes from scratch}
e86ac31 @jedi4ever first attempt to create vagrant plugin + gem
authored
13
14 s.required_rubygems_version = ">= 1.3.6"
15 s.rubyforge_project = "veewee"
16
8767e6c @jedi4ever This commit is mainly for offline backup purposes, don't rely on it
authored
17 # s.add_dependency "vagrant", "~> 0.8.2"
18 # s.add_dependency "libvirt"
e86ac31 @jedi4ever first attempt to create vagrant plugin + gem
authored
19 s.add_dependency "net-ssh", "~> 2.1.0"
20 s.add_dependency "popen4", "~> 0.1.2"
96bd8bb @jedi4ever added the export command
authored
21 s.add_dependency "thor", "~> 0.14.6"
a03ec83 @jedi4ever added highline gem
authored
22 s.add_dependency "highline", "~> 1.6.1"
61d5bb6 @jedi4ever cleaned up the output during the execution + major changes to make it…
authored
23 s.add_dependency "progressbar"
a953537 @jedi4ever added i18n gem to dependencies
authored
24 s.add_dependency "i18n"
dc05a52 @jedi4ever Added necessary requires for the new virtualbox gem as suggested by @…
authored
25 s.add_dependency "cucumber", "~> 1.0.2"
9726c41 @jedi4ever _test_ dependency fails, reverting
authored
26 s.add_dependency "rspec", "~> 2.5.0"
d27979d @jedi4ever Again, a massive chunk of restructuring current behavior
authored
27 s.add_dependency "ansi", "~> 1.3.0"
7db5231 @jedi4ever temporary backup
authored
28 s.add_dependency "ruby-vnc", "~> 1.0.0"
7f8bc52 @jedi4ever Cleanup setup.exe
authored
29 #s.add_dependency "simon", "~> 0.1.1"
e86ac31 @jedi4ever first attempt to create vagrant plugin + gem
authored
30
d96eac9 @jedi4ever trying to get the vagrant plugin to work
authored
31 s.add_development_dependency "bundler", ">= 1.0.0"
8767e6c @jedi4ever This commit is mainly for offline backup purposes, don't rely on it
authored
32 s.add_development_dependency('ruby-libvirt','~>0.4.0')
33
e86ac31 @jedi4ever first attempt to create vagrant plugin + gem
authored
34 s.files = `git ls-files`.split("\n")
35 s.executables = `git ls-files`.split("\n").map{|f| f =~ /^bin\/(.*)/ ? $1 : nil}.compact
36 s.require_path = 'lib'
37 end
38
Something went wrong with that request. Please try again.