Permalink
Browse files

moved em-winrm to a seperate bundle group to achieve ruby-1.8.7 compa…

…tibility
  • Loading branch information...
1 parent 4415b52 commit 53bc3213a4ebe68f5ada248dd9379755290421d4 @jedi4ever committed Apr 3, 2013
Showing with 10 additions and 2 deletions.
  1. +1 −1 .bundle/config
  2. +9 −1 doc/installation.md
View
@@ -1,2 +1,2 @@
----
+---
BUNDLE_WITHOUT: kvm
View
@@ -41,4 +41,12 @@ If you do need it, run `bundle install --without restrictions` (restrictions is
This will change the file `.bundle/config`, which is ignored by Git per default and must not be included in any commits.
As this is a remembered option, you don't have to specify it every time.
-If you want to switch to the default behavior run `bundle install --without kvm` to enable restrictions.
+If you want to switch to the default behavior run `bundle install --without kvm` to enable restrictions.
+
+### Running from source git repo and using ruby 1.8.7
+
+By default the :windows gem group is *enabled* . This loads the em-winrm gem which is incompatible with ruby-1.8.7 as it depends on the gss-api gem. To run from source you can do a `bundle install --without windows`
+
+This will change the file `.bundle/config`, which is ignored by Git per default and must not be included in any commits.
+If you want to switch to the default behavior run `bundle install --without restrictions` to include it
+

1 comment on commit 53bc321

Contributor

endemics commented on 53bc321 Apr 9, 2013

Brilliant! Thanks for maintaining the ruby 1.8.7 compatibility for those not using windows.

Please sign in to comment.