Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Veewee build error while creating base image for kvm. #470

Closed
sudhirpandey opened this Issue Jan 7, 2013 · 4 comments

Comments

Projects
None yet
3 participants

Hi i have ubuntu 12.04 host capable of running kvm , with no vagrant and virtual box installed. I have installed the veewee using gem install veewee.
Below is what i get when i try to build a kvm machine. Does any one have some idea where to look at, or face this problem before

veewee kvm build 'centos5.6-i386'
Building Box centos5.6-i386 with Definition centos5.6-i386:

  • force : false
  • auto : false
  • use_emulation : false
  • postinstall_include :
  • debug : false
  • postinstall_exclude :
  • nogui : false

The isofile CentOS-5.6-i386-netinstall.iso already exists.
/var/lib/gems/1.8/gems/fog-1.8.0/lib/fog/libvirt/models/compute/server.rb:66:in save': Error saving the server: Error creating the volume : undefined methodpersistent?' for #Libvirt::StoragePool:0x7f3149c79620 (Fog::Errors::Error)
from /var/lib/gems/1.8/gems/fog-1.8.0/lib/fog/core/collection.rb:50:in create' from /var/lib/gems/1.8/gems/veewee-0.3.6/lib/veewee/provider/kvm/box/create.rb:36:increate_server'
from /var/lib/gems/1.8/gems/veewee-0.3.6/lib/veewee/provider/kvm/box/create.rb:12:in create' from /var/lib/gems/1.8/gems/veewee-0.3.6/lib/veewee/provider/core/box/build.rb:42:inbuild'
from /var/lib/gems/1.8/gems/veewee-0.3.6/lib/veewee/provider/kvm/box/build.rb:6:in build' from /var/lib/gems/1.8/gems/veewee-0.3.6/lib/veewee/command/kvm.rb:17:inbuild'
from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/task.rb:27:in send' from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/task.rb:27:inrun'
from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/invocation.rb:120:in invoke_task' from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor.rb:275:indispatch'
from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/invocation.rb:109:in send' from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/invocation.rb:109:ininvoke'
from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor.rb:213:in kvm' from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/task.rb:27:insend'
from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/task.rb:27:in run' from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/invocation.rb:120:ininvoke_task'
from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor.rb:275:in dispatch' from /var/lib/gems/1.8/gems/thor-0.16.0/lib/thor/base.rb:425:instart'
from /var/lib/gems/1.8/gems/veewee-0.3.6/bin/veewee:23
from /usr/local/bin/veewee:19:in `load'
from /usr/local/bin/veewee:19

Owner

jedi4ever commented Jan 8, 2013

@sudhirpandey I suspect the fog api has changed and veewee needs to be adapted for it

Contributor

ffeldhaus commented Jan 10, 2013

Could you please check if the recent pull request #465 and #472 fixed your problem?

Owner

jedi4ever commented Jan 23, 2013

@sudhirpandey any updates/confirmation? Otherwise we close this ticket as resolved

Thanks a lot the latest 0.3.7 works great as expected for provisioning linux machines.

@jedi4ever jedi4ever closed this Feb 8, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment