Permalink
Browse files

update some docstrings

  • Loading branch information...
1 parent 028a870 commit 1d3ba73a7c0fb47aefda7b895035f714f9b69dc2 @jedie committed Jun 11, 2012
Showing with 13 additions and 9 deletions.
  1. +1 −1 creole/setup_utils.py
  2. +11 −7 creole/shared/html_parser.py
  3. +1 −1 creole/tests/test_setup_utils.py
View
@@ -38,7 +38,7 @@
)
---------------------------------------------------------------------------
- :copyleft: 2011 by the python-creole team, see AUTHORS for more details.
+ :copyleft: 2011-2012 by the python-creole team, see AUTHORS for more details.
:license: GNU GPL v3 or above, see LICENSE for more details.
"""
@@ -1,16 +1,20 @@
# coding: utf-8
"""
- Patched version of HTMLParser with patch from:
- http://bugs.python.org/issue670664
- See also:
- https://github.com/gregmuellegger/django/issues/1
-
- It was fixed with:
+ HTMLParser for Python 2.x and 3.x
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+ The HTMLParser has problems with the correct handling of <script>...</script>
+ and <style>...</style> areas.
+
+ It was fixed with v2.7.3 and 3.2.3, see:
http://www.python.org/download/releases/2.7.3/
http://www.python.org/download/releases/3.2.3/
see also:
http://bugs.python.org/issue670664#msg146770
+
+ :copyleft: 2011-2012 by python-creole team, see AUTHORS for more details.
+ :license: GNU GPL v3 or above, see LICENSE for more details.
"""
@@ -21,7 +25,7 @@
if hasattr(OriginHTMLParser, "cdata_elem"):
- # Current python version has
+ # Current python version is patched -> use the original
HTMLParser = OriginHTMLParser
else:
# Current python version is not patched -> use own patched version
@@ -7,7 +7,7 @@
https://code.google.com/p/python-creole/wiki/UseInSetup
- :copyleft: 2011 by python-creole team, see AUTHORS for more details.
+ :copyleft: 2011-2012 by python-creole team, see AUTHORS for more details.
:license: GNU GPL v3 or above, see LICENSE for more details.
"""

0 comments on commit 1d3ba73

Please sign in to comment.