Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Paperwork to create the 2.1.2-4 release of the plugin.

  • Loading branch information...
commit 543c639f0686027caa7f2388eb305c792e003e74 1 parent e89f2f6
@jeffellis authored Rally Dev Pair committed
View
10 CHANGELOG.md
@@ -0,0 +1,10 @@
+Plugin version numbers are constructed as a combination of the core metrics version plus the release of the plugin.
+For example, 2.1.2-4 is the fourth release of the plugin based on version 2.1.2 of the metrics jars.
+
+2.1.2-4: Jan 21 2013
+====================
+
+* Fixed [Issue #5:](https://github.com/jeffellis/grails-yammer-metrics/issues/5) Error in metrics servlet
+* Fixed [Issue #6:](https://github.com/jeffellis/grails-yammer-metrics/issues/6) Metrics servlet broken in Grails v2.2.0-RC2
+
+**Note:** To solve Issue #5, some package names were changed.
View
4 README.md
@@ -47,7 +47,7 @@ class SomeService{
Timed the Grails Way
```
class SomeService{
- @com.yammer.metrics.groovy.Timed
+ @org.grails.plugins.yammermetrics.groovy.Timed
public String serve(def foo, def bar) {
return "OK"
}
@@ -83,7 +83,7 @@ Metered the Grails Way
```
class SomeService{
- @com.yammer.metrics.groovy.Meter
+ @org.grails.plugins.yammermetrics.groovy.Meter
public String serve(def foo, def bar) {
return "OK"
}
View
7 YammerMetricsGrailsPlugin.groovy
@@ -4,7 +4,7 @@
class YammerMetricsGrailsPlugin {
// the plugin version
- def version = "2.1.2-3"
+ def version = "2.1.2-4"
// the version or versions of Grails the plugin is designed for
def grailsVersion = "2.0.3 > *"
// the other plugins this plugin depends on
@@ -15,7 +15,6 @@ class YammerMetricsGrailsPlugin {
"web-app/**"
]
- // TODO Fill in these fields
def author = "Jeff Ellis"
def authorEmail = "codemonkey@ellises.us"
def title = "Grails plugin to package Coda Hale's yammer metrics jars"
@@ -24,9 +23,7 @@ Provides the following features:
* metrics-core
* metrics-servlet (wired to the /metrics end point for the app).
-For detailed documentation on the yammer metrics package see:
-
-http://metrics.codahale.com/index.html
+See the source code documentation on Github for more details.
'''
// URL to the plugin's documentation
View
3  application.properties
@@ -1,5 +1,4 @@
#Grails Metadata file
-#Mon Sep 24 17:23:19 EDT 2012
+#Mon Jan 21 16:13:27 EST 2013
app.grails.version=2.1.1
app.name=yammer-metrics
-plugins.rest-client-builder=1.0.2
View
2  grails-app/conf/BuildConfig.groovy
@@ -34,7 +34,7 @@ grails.project.dependency.resolution = {
}
plugins {
- build ':release:2.0.3', {
+ build ':release:2.2.0', {
export = false
}
Please sign in to comment.
Something went wrong with that request. Please try again.