Permalink
Browse files

Fixed supported for the new datamapper gems

  • Loading branch information...
1 parent b3ff462 commit 12db7c308c5398f469c267a9d7ff8374b6a43404 @antekpiechnik antekpiechnik committed Aug 12, 2010
Showing with 35 additions and 9 deletions.
  1. +2 −0 Gemfile
  2. +29 −9 Gemfile.lock
  3. +1 −0 lib/navvy/job/data_mapper.rb
  4. +3 −0 navvy.gemspec
View
@@ -6,6 +6,8 @@ end
group :data_mapper do
gem 'dm-core', '>= 0.10.2'
+ gem 'dm-sqlite-adapter'
+ gem 'dm-migrations'
end
group :mongo_mapper do
View
@@ -9,32 +9,47 @@ GEM
activerecord (2.3.8)
activesupport (= 2.3.8)
activesupport (2.3.8)
- addressable (2.1.2)
- bson (1.0.3)
+ addressable (2.2.0)
+ bson (1.0.4)
+ bson_ext (1.0.4)
builder (2.1.2)
+ data_objects (0.10.2)
+ addressable (~> 2.1)
dm-core (1.0.0)
addressable (~> 2.1)
extlib (~> 0.9.15)
+ dm-do-adapter (1.0.0)
+ data_objects (~> 0.10.1)
+ dm-core (~> 1.0.0)
+ dm-migrations (1.0.0)
+ dm-core (~> 1.0.0)
+ dm-sqlite-adapter (1.0.0)
+ dm-do-adapter (~> 1.0.0)
+ do_sqlite3 (~> 0.10.2)
+ do_sqlite3 (0.10.2)
+ data_objects (= 0.10.2)
durran-validatable (2.0.1)
extlib (0.9.15)
jnunemaker-validatable (1.8.4)
activesupport (>= 2.3.4)
- mongo (1.0.3)
- bson (= 1.0.3)
- mongo_mapper (0.8.2)
+ mongo (1.0.7)
+ bson (>= 1.0.4)
+ mongo_mapper (0.8.3)
activesupport (>= 2.3.4)
jnunemaker-validatable (~> 1.8.4)
- plucky (~> 0.3.1)
+ plucky (~> 0.3.3)
mongoid (1.9.1)
activesupport (<= 3.0.0)
bson (~> 1.0.1)
durran-validatable (>= 2.0.1)
mongo (~> 1.0.1)
will_paginate (< 2.9)
- plucky (0.3.2)
- mongo (~> 1.0.1)
+ plucky (0.3.4)
+ mongo (~> 1.0.7)
+ rake (0.8.7)
rspec (1.3.0)
- sequel (3.13.0)
+ sequel (3.14.0)
+ sqlite3-ruby (1.3.1)
timecop (0.3.5)
tzinfo (0.3.22)
will_paginate (2.3.14)
@@ -45,13 +60,18 @@ PLATFORMS
DEPENDENCIES
activerecord (>= 2.3.5)
+ bson_ext
builder
dm-core (>= 0.10.2)
+ dm-migrations
+ dm-sqlite-adapter
mongo_mapper (>= 0.7.0)
mongoid
navvy!
+ rake
rspec (>= 1.2.9)
sequel (>= 3.8.0)
+ sqlite3-ruby
timecop (>= 0.3.5)
tzinfo
yard (>= 0.5.2)
@@ -1,4 +1,5 @@
require 'dm-core'
+require 'dm-migrations'
module Navvy
class Job
View
@@ -12,6 +12,9 @@ Gem::Specification.new do |gem|
gem.files = Dir['{generators,lib,spec}/**/*', 'README*', 'LICENSE*'] & `git ls-files -z`.split("\0")
+ gem.add_development_dependency('rake')
+ gem.add_development_dependency('sqlite3-ruby')
+ gem.add_development_dependency('bson_ext')
gem.add_development_dependency('rspec', [">= 1.2.9"])
gem.add_development_dependency('yard', [">= 0.5.2"])
gem.add_development_dependency('timecop', [">= 0.3.5"])

0 comments on commit 12db7c3

Please sign in to comment.