Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge branch 'develop' of github.com:jeffsu/mochiscript into develop

Conflicts:
	VERSION
	platforms/gem/lib/mochiscript/version.rb
	platforms/npm/package.json
  • Loading branch information...
commit f020829106737682b3592ed55772e29482a5af21 2 parents 9a87745 + 287c903
@jeffsu authored
View
15 CHANGELOG
@@ -1,12 +1,23 @@
+### 0.5.6
+
+ * merged 0.5.4
+
+### 0.5.5
+
+ * compile support for connect
+
+### 0.5.4
+
+ * added haml filter support
+
### 0.5.3
* fixed self problem in bootstrap
-
+
### 0.5.2
* fixed #3
-
### 0.5.0
* adding shortcut for returning "=> foo"
View
2  VERSION
@@ -1 +1 @@
-0.5.5
+0.5.6
View
16 platforms/gem/lib/mochiscript/haml.rb
@@ -0,0 +1,16 @@
+require 'haml'
+
+module Haml::Filters::Mochiscript
+ include ::Haml::Filters::Base
+
+ def render(text)
+ ctx = Mochiscript::Context.new
+ <<END
+<script type="text/javascript">
+ //<![CDATA[
+ #{ctx.parse(text)}
+ //]]>
+</script>
+END
+ end
+end
View
1  platforms/gem/lib/mochiscript/rails/engine.rb
@@ -1,4 +1,5 @@
require 'sprockets'
+require 'sprockets/engines'
class Engine < ::Rails::Engine
end
View
2  platforms/gem/lib/mochiscript/version.rb
@@ -1,3 +1,3 @@
module Mochiscript
- VERSION = "0.5.5"
+ VERSION = "0.5.6"
end
View
2  platforms/npm/package.json
@@ -3,7 +3,7 @@
"description": "Javascript Dessert",
"keywords": [ "javascript", "language", "mochiscript", "compiler" ],
"author": "Jeff Su",
- "version": "0.5.5",
+ "version": "0.5.6",
"licenses": [ { "type": "MIT" }],
"engines": { "node": ">=0.4.0" },
"directories": { "lib": "./lib/mochiscript" },
Please sign in to comment.
Something went wrong with that request. Please try again.