Skip to content

Mercury won't run on Rails 3.2.0.rc1 #114

aaronbrethorst opened this Issue Dec 20, 2011 · 3 comments

3 participants


because the gemspec specifically requires 3.1.x:

s.add_runtime_dependency('rails', ["~> 3.1.0"])

Have you gotten it to run in 3.2.0rc to figure out if it does actually work?

So, the reason it's locked to a version around 3.1.0 is so people wouldn't create issues if it doesn't work in future versions -- that's what the ~> means ... "approximate version". Give it a go by editing the gemspec in your gem and let me know your findings.

  1. bundle show mercury-rails
  2. mate [whatever that path is]/mercury-rails.gemspec
  3. make the change to so it will attempt to run on rails 3.2.0rcX .. "> 3.1.0"
  4. report findings. =)

I tested and it works fine with my Rails 3.2.0 app. I think you can update the gemspec.

@jejacks0n jejacks0n closed this in 2127048 Jan 21, 2012

thanks for the heads up. =)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.