because the gemspec specifically requires 3.1.x:
s.add_runtime_dependency('rails', ["~> 3.1.0"])
Have you gotten it to run in 3.2.0rc to figure out if it does actually work?
So, the reason it's locked to a version around 3.1.0 is so people wouldn't create issues if it doesn't work in future versions -- that's what the ~> means ... "approximate version". Give it a go by editing the gemspec in your gem and let me know your findings.
bundle show mercury-rails
mate [whatever that path is]/mercury-rails.gemspec
I tested and it works fine with my Rails 3.2.0 app. I think you can update the gemspec.
allow for future versions of rails (min requirement is 3.1.0) -- fixes …
thanks for the heads up. =)