Skip to content
This repository has been archived by the owner. It is now read-only.

FreeBSD: Could not find kramdown #46

Closed
neelchauhan opened this Issue May 13, 2014 · 5 comments

Comments

Projects
None yet
4 participants
@neelchauhan
Copy link

neelchauhan commented May 13, 2014

Hi,
When I try to run jekyll new bloglocation on FreeBSD 10.0, I get this error:

/usr/local/lib/ruby/site_ruby/2.1/rubygems/dependency.rb:247:in `to_specs': Could not find kramdown (~> 1.0.2) amongst [classifier-1.3.3, colorator-0.1, commander-4.1.4, directory_watcher-1.4.1, fast-stemmer-1.0.2, highline-1.6.21, jekyll-1.0.3, kramdown-1.3.3, liquid-2.5.0, maruku-0.6.1, posix-spawn-0.3.6, pygments.rb-0.5.4, safe_yaml-0.9.4, syntax-1.0.0, yajl-ruby-1.2.0] (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems/specification.rb:778:in `block in activate_dependencies'
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems/specification.rb:767:in `each'
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems/specification.rb:767:in `activate_dependencies'
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems/specification.rb:751:in `activate'
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems.rb:1232:in `gem'
        from /usr/local/bin/jekyll:22:in `<main>'

Ruby says I have kramdown on my computer, so why is it giving an error that kramdown isn't installed on my computer? I installed Jekyll from FreeBSD ports, and set the default Ruby version to 2.1.
BTW I have posted this issue on Jekyll's main GitHub repo, but @parktr said to come here.

@JesseHerrick

This comment has been minimized.

Copy link

JesseHerrick commented May 27, 2014

What version of Kramdown do you have? kramdown -v

@parkr

This comment has been minimized.

Copy link
Member

parkr commented May 27, 2014

It's looking for Kramdown ~> 1.0.2 (>= 1.0.2, < 1.1), but you have 1.3.3 installed.

@neelchauhan

This comment has been minimized.

Copy link
Author

neelchauhan commented May 27, 2014

@parkr I have a question.
Why can't Jekyll work with Kramdown 1.3.3? I know how to code, but I don't know Ruby (have no interest, to the extent that I'd rather learn assembly language!)

@parkr

This comment has been minimized.

Copy link
Member

parkr commented May 27, 2014

You're running an old version of Jekyll there. The latest gemspec is ~> 1.3, which would include anything above 1.3.0 before 2.0.0.

@troyswanson

This comment has been minimized.

Copy link
Member

troyswanson commented Jul 7, 2014

Going to close this one out since it looks like @parkr's solution ought to work. Feel free to add another comment if you need more help, or just open a new issue if something new comes up.

@troyswanson troyswanson closed this Jul 7, 2014

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.