Index gets last page, no other page is generated #14

Open
Darkhogg opened this Issue Oct 15, 2014 · 3 comments

Comments

Projects
None yet
3 participants
@Darkhogg

This is exactly the same problem described at jekyll/jekyll#1063 and jekyll/jekyll#1058, but I'm seeing it both locally on a Linux system and in GitHub pages.

You can find an example of the problem here:

As you see, the index shows page 3 and actual pages 2 and 3 are nonexistant.

Now, I really don't know whose fault this is, mine or jekyll's, but as the symptoms are not new, I'm assuming jekyll's. Is there some workaround I can use?

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Oct 15, 2014

Member

I cloned your repo and ran jekyll serve and it didn't work, but because some vendored assets aren't there. There seems to be a larger issue here.

Member

parkr commented Oct 15, 2014

I cloned your repo and ran jekyll serve and it didn't work, but because some vendored assets aren't there. There seems to be a larger issue here.

@Darkhogg

This comment has been minimized.

Show comment
Hide comment
@Darkhogg

Darkhogg Oct 15, 2014

@parkr Be sure to git submodule init and git submodule update if you clone it, as well as installing the jekyll-redirect-from gem.

@parkr Be sure to git submodule init and git submodule update if you clone it, as well as installing the jekyll-redirect-from gem.

@sankage

This comment has been minimized.

Show comment
Hide comment
@sankage

sankage Feb 11, 2015

As I just ran into this as well, in my case this was resolved by removing the permalink from the blog index page, as per #23

sankage commented Feb 11, 2015

As I just ran into this as well, in my case this was resolved by removing the permalink from the blog index page, as per #23

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment