Skip to content
Browse files

Extension -> Plugin

  • Loading branch information...
1 parent 5335deb commit 31c65c56f4989435301eee622ee375cee4bf2de2 @mojombo mojombo committed
Showing with 8 additions and 6 deletions.
  1. +2 −0 History.txt
  2. +2 −2 lib/jekyll.rb
  3. +1 −1 lib/jekyll/converter.rb
  4. +1 −1 lib/jekyll/generator.rb
  5. +2 −2 lib/jekyll/{extension.rb → plugin.rb}
View
2 History.txt
@@ -1,4 +1,6 @@
== Edge
+ * Major Enhancements
+ * Proper plugin system (#19, #100)
* Minor Enhancements
* Inclusion/exclusion of future dated posts (#59)
* Generation for a specific time (#59)
View
4 lib/jekyll.rb
@@ -35,8 +35,8 @@ def require_all(path)
require 'jekyll/albino'
require 'jekyll/static_file'
-#extensions
-require 'jekyll/extension'
+# extensions
+require 'jekyll/plugin'
require 'jekyll/converter'
require 'jekyll/generator'
require_all 'jekyll/converters'
View
2 lib/jekyll/converter.rb
@@ -1,6 +1,6 @@
module Jekyll
- class Converter < Extension
+ class Converter < Plugin
# Public: Get or set the pygments prefix. When an argument is specified,
# the prefix will be set. If no argument is specified, the current prefix
# will be returned.
View
2 lib/jekyll/generator.rb
@@ -1,6 +1,6 @@
module Jekyll
- class Generator < Extension
+ class Generator < Plugin
end
View
4 lib/jekyll/extension.rb → lib/jekyll/plugin.rb
@@ -1,6 +1,6 @@
module Jekyll
- class Extension
+ class Plugin
PRIORITIES = { :lowest => -100,
:low => -10,
:normal => 0,
@@ -49,7 +49,7 @@ def self.<=>(other)
PRIORITIES[other.priority] <=> PRIORITIES[self.priority]
end
- # Initialize a new extension. This should be overridden by the subclass.
+ # Initialize a new plugin. This should be overridden by the subclass.
#
# config - The Hash of configuration options.
#

0 comments on commit 31c65c5

Please sign in to comment.
Something went wrong with that request. Please try again.