Permalink
Browse files

Trys to require RDiscount and falls back gracefully, added require fo…

…r the new blocks module
  • Loading branch information...
1 parent 08bf7b1 commit e2678114d9d5774daa6782d70260e885567e08c7 Chris Van Pelt committed Nov 23, 2008
Showing with 2 additions and 0 deletions.
  1. +2 −0 lib/jekyll.rb
View
@@ -12,6 +12,7 @@
# 3rd party
require 'liquid'
require 'redcloth'
+require 'rdiscount' rescue puts "The rdiscount gem is required for markdown support!"
require 'classifier'
# internal requires
@@ -21,6 +22,7 @@
require 'jekyll/page'
require 'jekyll/post'
require 'jekyll/filters'
+require 'jekyll/blocks'
module Jekyll
VERSION = '0.1.2'

0 comments on commit e267811

Please sign in to comment.