Permalink
Browse files

Switch to `gem 'wdm', '~> 0.1.1', :install_if => Gem.win_platform?` (#…

…7372)

Merge pull request 7372
  • Loading branch information...
XhmikosR authored and jekyllbot committed Nov 24, 2018
1 parent c8bd59b commit fa914d2dd85f8263d599f41e5a67c109b1d8b52c
Showing with 2 additions and 2 deletions.
  1. +1 −1 docs/_docs/installation/windows.md
  2. +1 −1 lib/jekyll/commands/new.rb
@@ -55,7 +55,7 @@ Jekyll uses the `listen` gem to watch for changes when the `--watch` switch is s
Add the following to the `Gemfile` for your site if you have issues with auto-regeneration on Windows alone:
```ruby
gem 'wdm', '~> 0.1.1' if Gem.win_platform?
gem 'wdm', '~> 0.1.1', :install_if => Gem.win_platform?
```
You have to use a [Ruby+Devkit](https://rubyinstaller.org/downloads/) version of the RubyInstaller.
@@ -91,7 +91,7 @@ def gemfile_contents
# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem "tzinfo-data", platforms: [:mingw, :mswin, :x64_mingw, :jruby]
# Performance-booster for watching directories on Windows
gem "wdm", "~> 0.1.0" if Gem.win_platform?
gem "wdm", "~> 0.1.1", :install_if => Gem.win_platform?
RUBY
end

0 comments on commit fa914d2

Please sign in to comment.