New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

syntax highlighting silently doesn't work in 0.5.6 #116

Closed
davetron5000 opened this Issue Jan 9, 2010 · 7 comments

Comments

Projects
None yet
5 participants
@davetron5000

davetron5000 commented Jan 9, 2010

0.5.4 my blog posts got syntax highlighting via pygments fine. When I updated to 0.5.6, the code blocks don't show up in the output, and there's no messages from jekyll that anything is wrong. Updated pygments to 1.2.2 but that didn't fix it.

jekyll --pygmentize --server

My posts (in HTML) look like this:

{% highlight ruby %}
include Java

blah = java.util.Date.new
{% endhighlight %}
@mojombo

This comment has been minimized.

Contributor

mojombo commented Jan 9, 2010

I am unable to duplicate this locally. Pygments highlighting works for me in 0.5.6. Are you using GitHub pages? If so, does the problem persist on deploy?

@kez

This comment has been minimized.

kez commented Jan 9, 2010

Isn't it --pygments, not --pygmentize?

@davetron5000

This comment has been minimized.

davetron5000 commented Jan 9, 2010

Yeah, I mistyped it here. Actual command was:

jekyll --pygments --serve

@mojombo: I'm running this locally on OS X 10.6.2 and publishing to my own hosted server (gh-pages isn't a part of the process). Are there some other dependencies that come into play here that I can check? More version info below:

> ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [universal-darwin10.0]
> python -V
Python 2.6.1
> gem list

*** LOCAL GEMS ***

actionmailer (2.3.2, 2.2.2, 2.1.2, 2.1.1, 1.3.6)
actionpack (2.3.2, 2.2.2, 2.1.2, 2.1.1, 1.13.6)
actionwebservice (1.2.6)
activerecord (2.3.2, 2.2.2, 2.1.2, 2.1.1, 1.15.6)
activeresource (2.3.2, 2.2.2, 2.1.2, 2.1.1)
activesupport (2.3.2, 2.2.2, 2.1.2, 2.1.1, 1.4.4)
acts_as_ferret (0.4.4, 0.4.3)
builder (2.1.2)
capistrano (2.5.9, 2.5.5, 2.5.4, 2.5.2, 2.5.0)
cgi_multipart_eof_fix (2.5.0)
claret-cli (0.5.7)
classifier (1.3.1)
commandline (0.7.10)
configuration (1.1.0)
crack (0.1.2, 0.1.1)
cucumber (0.6.1, 0.3.11, 0.3.6, 0.3.2, 0.3.0)
cucumber-rails (0.2.3)
daemons (1.0.10)
database_cleaner (0.4.0)
davetron5000-daves-resume (0.1.2)
davetron5000-gliffy (0.9.5, 0.9.3, 0.9.2)
davetron5000-grit (1.1.3)
davetron5000-rest-client (0.5.3)
diff-lcs (1.1.2)
directory_watcher (1.2.0, 1.1.2)
dnssd (0.7.1, 0.7.0, 0.6.0)
echoe (4.0, 3.1.1, 3.1, 3.0.2)
faker (0.3.1)
fastthread (1.0.7, 1.0.1)
fcgi (0.8.7)
ferret (0.11.6)
gash (0.1.3)
gem_plugin (0.2.3)
gemcutter (0.2.1, 0.1.5)
getopt (1.3.8, 1.3.7)
git (1.2.5, 1.1.1)
gitjour (6.5.0)
gli (1.1.0, 1.0.0, 0.2.3, 0.2.1)
grancher (0.1)
haml (2.0.9, 2.0.8, 2.0.6)
heroku (1.3.0)
highline (1.5.1, 1.5.0, 1.4.0)
hoe (2.4.0, 2.2.0, 1.12.2, 1.10.0, 1.8.3, 1.8.2)
hpricot (0.8.1, 0.6.164, 0.6.161)
httparty (0.4.3, 0.4.2, 0.3.1)
jekyll (0.5.4, 0.4.1)
jeweler (1.4.0)
json (1.2.0)
json_pure (1.2.0, 1.1.9)
launchy (0.3.3)
libxml-ruby (1.1.3, 1.1.2, 1.1.1, 0.9.8, 0.8.3)
liquid (2.0.0, 1.9.0)
maruku (0.6.0, 0.5.9)
mechanize (0.9.3, 0.9.2)
mime-types (1.16)
mislav-hanna (0.1.7, 0.1.6)
mocha (0.9.5)
mongrel (1.1.5)
moocow (1.0.0, 0.1.3)
mysql (2.7)
needle (1.3.0)
net-scp (1.0.2, 1.0.1)
net-sftp (2.0.2, 2.0.1, 1.1.1)
net-ssh (2.0.15, 2.0.11, 2.0.10, 2.0.4, 1.1.4)
net-ssh-gateway (1.0.1, 1.0.0)
nokogiri (1.4.1)
notahat-machinist (1.0.3, 0.3.1)
oauth (0.3.5, 0.3.4, 0.3.3, 0.3.2)
open4 (0.9.6)
polyglot (0.2.9, 0.2.6, 0.2.5)
prawn (0.6.3)
prawn-core (0.6.3)
prawn-format (0.2.3)
prawn-layout (0.3.2)
prawn-security (0.1.1)
rack (1.0.0)
rails (2.3.2, 2.2.2, 2.1.2, 2.1.1, 1.2.6)
rainbow (1.0.4)
rake (0.8.7, 0.8.4, 0.8.3)
rcov (0.9.6, 0.8.1.2.0)
rdiscount (1.3.4, 1.3.1.1, 1.2.11)
rdoc (2.4.3, 2.4.1, 2.3.0, 2.2.1)
RedCloth (4.2.2, 4.1.1)
rest-client (1.0.3)
rspec (1.2.9, 1.2.6, 1.1.12)
rspec-rails (1.2.9, 1.2.6)
rtf (0.1.0)
ruby-hmac (0.3.2)
ruby-openid (2.1.6, 2.1.4, 2.1.2)
ruby-yadis (0.3.4)
rubyforge (2.0.3, 1.0.3, 1.0.2, 1.0.1)
rubygems-update (1.3.5, 1.3.4, 1.3.3, 1.3.1, 1.3.0)
rubynode (0.1.5)
schacon-git (1.1.1, 1.0.7)
schacon-git-lighthouse (0.1.2)
sequel (3.1.0, 3.0.0, 2.11.0, 2.10.0, 2.9.0)
sqlite3-ruby (1.2.4)
stemmer (1.0.1)
syntax (1.0.0)
technicalpickles-jeweler (1.0.1)
term-ansicolor (1.0.4, 1.0.3)
termios (0.9.4)
test-unit (2.0.2)
text-format (1.0.0)
text-hyphen (1.0.0)
treetop (1.4.3, 1.2.6, 1.2.5)
tzinfo (0.3.13, 0.3.12)
webrat (0.6.0, 0.4.4)
xmpp4r (0.4)
yumlcmd (0.0.3)
@mojombo

This comment has been minimized.

Contributor

mojombo commented Jan 10, 2010

Is the full source code of your site available so that I can test it locally and more easily track down the cause of this problem?

@davetron5000

This comment has been minimized.

@mojombo

This comment has been minimized.

Contributor

mojombo commented Jan 14, 2010

Render highlighted code for non markdown/textile pages. Closed by 2b2e027

@tomstuart

This comment has been minimized.

tomstuart commented Apr 13, 2010

Is this fix likely to be rolled into GitHub pages any time soon?

@jekyll jekyll locked and limited conversation to collaborators Feb 27, 2017

This issue was closed.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.