Extra tags added on compile #2313

Closed
devinhalladay opened this Issue May 7, 2014 · 2 comments

Projects

None yet

2 participants

@devinhalladay

For some reason Jekyll is adding extra <p> tags when my site is compiled. Here's the markup in my source:

<div class="large-3 small-12 columns">
  <small>
    <h3 class="serif-sc">Get in Touch</h3>
    <p>
      <li><a href="http://twitter.com/devinhalladay">Twitter</a></li>
      <li><a href="http://facebook.com/thehalladay">Facebook</a></li>
      <li><a href="http://dribbble.com/devinhalladay">Dribbble</a></li>
      <li><a href="mailto:devin@devinhalladay.com">Email</a></li>
    </p>
  </small>
</div>

Here's the markup that's rendered:

<div class="large-3 small-12 columns">
  <small>
    <h3 class="serif-sc">Get in Touch</h3>
    <p>
              </p>
    <li><a href="http://twitter.com/devinhalladay">Twitter</a></li>
    <li><a href="http://facebook.com/thehalladay">Facebook</a></li>
    <li><a href="http://dribbble.com/devinhalladay">Dribbble</a></li>
    <li><a href="mailto:devin@devinhalladay.com">Email</a></li>
    <p></p>
  </small>
</div>

I've talked to a friend (@ColeTownsend) and he says he's experiencing the issue as well. I've looked into the source code as well as all the plugins I use but the suspect isn't in my plugins and I wasn't able to locate anything in the Jekyll source.

Any ideas?

@mscharley
@devinhalladay

Oh, duh! I can't believe I missed that. It's been a long day...

image

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment