New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Could not find gem 'jekyll-sitemap' in any of the gem sources listed in your Gemfile or available on this machine. (Bundler::GemNotFound) #4972

Closed
wittyResry opened this Issue Jun 1, 2016 · 6 comments

Comments

Projects
None yet
4 participants
@wittyResry

wittyResry commented Jun 1, 2016

image

@wittyResry

This comment has been minimized.

wittyResry commented Jun 1, 2016

$ sudo gem install jekyll-sitemap

@wittyResry

This comment has been minimized.

wittyResry commented Jun 1, 2016

➜  wittyResry.github.io git:(master) ✗ jekyll serve
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/universal-darwin15/rbconfig.rb:213: warning: Insecure world writable dir /Users/resry/alipay/apache-maven-2.2.1/bin in PATH, mode 040777
/Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/resolver.rb:356:in `block in verify_gemfile_dependencies_are_found!': Could not find gem 'pygments.rb' in any of the gem sources listed in your Gemfile or available on this machine. (Bundler::GemNotFound)
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/resolver.rb:331:in `each'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/resolver.rb:331:in `verify_gemfile_dependencies_are_found!'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/resolver.rb:200:in `start'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/resolver.rb:184:in `resolve'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/definition.rb:200:in `resolve'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/definition.rb:140:in `specs'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/definition.rb:185:in `specs_for'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/definition.rb:174:in `requested_specs'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/environment.rb:19:in `requested_specs'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler/runtime.rb:14:in `setup'
    from /Library/Ruby/Gems/2.0.0/gems/bundler-1.12.5/lib/bundler.rb:95:in `setup'
    from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.1.6/lib/jekyll/plugin_manager.rb:33:in `require_from_bundler'
    from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.1.6/bin/jekyll:9:in `<top (required)>'
    from /usr/local/bin/jekyll:23:in `load'
    from /usr/local/bin/jekyll:23:in `<main>
@wittyResry

This comment has been minimized.

wittyResry commented Jun 1, 2016

$ sudo gem install pygments.rb

@wittyResry wittyResry closed this Jun 1, 2016

@kevinnerd

This comment has been minimized.

kevinnerd commented Feb 27, 2017

Thanks for solving my problem~

@gusg21

This comment has been minimized.

gusg21 commented Mar 19, 2017

mine too

@researcherGeekLab

This comment has been minimized.

researcherGeekLab commented Jul 20, 2017

$ sudo gem install pygments.rb
$ gem install bundler
$ bundle install

@jekyll jekyll locked and limited conversation to collaborators Jul 20, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.