Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Using locomotive_liquid instead of liquid gem #642

Closed
hipertracker opened this Issue Sep 17, 2012 · 1 comment

Comments

Projects
None yet
3 participants

How could I force Jekyll to work with locomotive_liquid instead of old liquid gem?

locomotive_liquid is more powerful, e.g. it has very useful extends command) see: https://github.com/locomotivecms/liquid/blob/master/spec/integration/extends_spec.rb.

PS. From my experience Liquid is a poor offspring of Django templates. Adding the inheritance could help to simplify jekyll templates structure a lot. Have a look how it could look: https://github.com/lakshmivyas/hyde/tree/master/templates/default_html5 (that's Hyde, similar project, except it is written in Python and use Django templates).

Owner

parkr commented Mar 19, 2013

Take a look at the do_render method in the Convertible module. You'll have to override that.

@parkr parkr closed this Mar 19, 2013

@jekyllbot jekyllbot locked and limited conversation to collaborators Feb 27, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.