New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rouge's Redcarpet plugin now has a different API #2951

Merged
merged 2 commits into from Sep 25, 2014

Conversation

Projects
None yet
4 participants
@parkr
Member

parkr commented Sep 23, 2014

@parkr parkr added the fix label Sep 23, 2014

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Sep 23, 2014

Member

We should get a PATCH build out for this and probably bump the MINOR version of Rouge, too.

Member

parkr commented Sep 23, 2014

We should get a PATCH build out for this and probably bump the MINOR version of Rouge, too.

parkr added a commit that referenced this pull request Sep 25, 2014

@parkr parkr merged commit 0c32f38 into master Sep 25, 2014

1 check passed

continuous-integration/travis-ci The Travis CI build passed
Details

@parkr parkr deleted the fix-rouge branch Sep 25, 2014

parkr added a commit that referenced this pull request Sep 25, 2014

@mrmartineau

This comment has been minimized.

Show comment
Hide comment
@mrmartineau

mrmartineau Oct 6, 2014

Are these changes in the current or pre-release version of jekyll now?

mrmartineau commented Oct 6, 2014

Are these changes in the current or pre-release version of jekyll now?

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Oct 6, 2014

Member

Not yet, no. For now, downgrade Rouge. I'll cut a 2.4.1 soon!

Member

parkr commented Oct 6, 2014

Not yet, no. For now, downgrade Rouge. I'll cut a 2.4.1 soon!

@parkr parkr referenced this pull request Oct 6, 2014

Closed

Cut a :gem: v2.4.1 #2976

@schneems

This comment has been minimized.

Show comment
Hide comment
@schneems

schneems Nov 3, 2014

Contributor

I tried downgrading rouge and it doesn't work?

Installing rouge 1.5.1 (was 1.6.2)
Your bundle is updated!
2.1.3  ~/documents/projects/schneems (master)
$ jekyll serve -w
Configuration file: /Users/richardschneeman/documents/projects/schneems/_config.yml
            Source: /Users/richardschneeman/documents/projects/schneems
       Destination: /Users/richardschneeman/documents/projects/schneems/_site
      Generating...
  Conversion error: Jekyll::Converters::Markdown encountered an error converting '_posts/tumblr/2013-09-17-explain-shell-from-your-shell.md'.
  Conversion error: undefined method `merge' for #<Rouge::Lexers::Shell:0x007fbd1c3dd728 @options={}, @debug=nil>
jekyll 2.4.0 | Error:  undefined method `merge' for #<Rouge::Lexers::Shell:0x007fbd1c3dd728 @options={}, @debug=nil>

I've tried a ton of different versions. Any ideas?

Contributor

schneems commented Nov 3, 2014

I tried downgrading rouge and it doesn't work?

Installing rouge 1.5.1 (was 1.6.2)
Your bundle is updated!
2.1.3  ~/documents/projects/schneems (master)
$ jekyll serve -w
Configuration file: /Users/richardschneeman/documents/projects/schneems/_config.yml
            Source: /Users/richardschneeman/documents/projects/schneems
       Destination: /Users/richardschneeman/documents/projects/schneems/_site
      Generating...
  Conversion error: Jekyll::Converters::Markdown encountered an error converting '_posts/tumblr/2013-09-17-explain-shell-from-your-shell.md'.
  Conversion error: undefined method `merge' for #<Rouge::Lexers::Shell:0x007fbd1c3dd728 @options={}, @debug=nil>
jekyll 2.4.0 | Error:  undefined method `merge' for #<Rouge::Lexers::Shell:0x007fbd1c3dd728 @options={}, @debug=nil>

I've tried a ton of different versions. Any ideas?

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Nov 3, 2014

Member

Just looked through jneen/rouge#182 again and it looks like if you go to <= 1.6.2, you should be good to go. Try running bundle exec jekyll serve instead?

Member

parkr commented Nov 3, 2014

Just looked through jneen/rouge#182 again and it looks like if you go to <= 1.6.2, you should be good to go. Try running bundle exec jekyll serve instead?

@schneems

This comment has been minimized.

Show comment
Hide comment
@schneems

schneems Nov 3, 2014

Contributor

genius! Wow, someone should really write a blog post on this whole bundle exec thing, it's really hot potatoes 😁 👍 ❤️ 🙈

Contributor

schneems commented Nov 3, 2014

genius! Wow, someone should really write a blog post on this whole bundle exec thing, it's really hot potatoes 😁 👍 ❤️ 🙈

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Nov 3, 2014

Member

Hahaha, glad it worked! 😄 We'll try to get a fix out for this soon. Sorry for the headache!

Member

parkr commented Nov 3, 2014

Hahaha, glad it worked! 😄 We'll try to get a fix out for this soon. Sorry for the headache!

@jekyll jekyll locked and limited conversation to collaborators Feb 27, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.